FIX: Long delays may occur before the server sends acknowledgements to client Message Queuing messages in BizTalk Server 2004 (884017)



The information in this article applies to:

  • Microsoft BizTalk Server 2004 Enterprise Edition
  • Microsoft BizTalk Server 2004 Standard Edition
  • Microsoft BizTalk Server 2004 Partner Edition
  • Microsoft BizTalk Server 2004 Developer Edition

SYMPTOMS

When you use Microsoft Message Queuing (also known as MSMQ) to send a message to a BizTalk Message Queuing Adapter (MSMQT) receive port on a computer that is running Microsoft BizTalk Server 2004, delays of more than five minutes may occur before the server responds.

CAUSE

This problem occurs because the difference between the local time and Coordinated Universal Time (Greenwich Mean Time) is not an exact multiple of 60 minutes. For example, India is 5 hours and 30 minutes ahead of Coordinated Universal Time. In this case, the message box conversion from Coordinated Universal Time to local time does not consider the minute part of the time. MSMQT uses timer messages to periodically send order acknowledgements (OrderACK). Because of the time conversion problem, the timers are not started in the first 30 minutes of any hour. Therefore, the acknowledgements are not sent.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft BizTalk Server 2004 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must install BizTalk Server 2004 Rollup Package 1 before you install this hotfix.

Restart requirement

After you install this hotfix, you must restart the BizTalk Server 2004 service.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Date         Time    Version     Size     File name
--------------------------------------------------------------------------
18-Aug-2004  21:00               414,488  Bts_administration_logic.sql
18-Aug-2004  21:00               298,154  Msgboxlogic.sql
   


Note Because of file dependencies, the most recent hotfix that contains these files may also contain additional files.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:4/7/2006
Keywords:kbQFE KBHotfixServer kbBTSMessaging kbBizTalk2004preSP1fix kbbug kbfix KB884017 kbAudDeveloper