Systems Management Server 2003 Remote Control Client does not display current Remote Control Status (883983)



The information in this article applies to:

  • Microsoft Systems Management Server 2003

Important This article contains information that shows you how to help lower security settings or how to turn off security features on a computer. You can make these changes to work around a specific problem. Before you make these changes, we recommend that you evaluate the risks that are associated with implementing this workaround in your particular environment. If you implement this workaround, take any appropriate additional steps to help protect your system.

SYMPTOMS

When you view the Components tab in the Systems Management item in Control Panel on a Microsoft Systems Management Server 2003 (SMS 2003) client, the Remote Control status shows Installed, but it does not show Enabled. When you double-click the Remote Control icon in Control Panel, you may receive the following message:
Cannot display current remote control status. The remote control service agent is not started
.

Additionally, the Ccmexec.log file that is located in the %Windir%\System32\CCM\Logs folder on the SMS 2003 client may contain information that is similar to the following:
[LOG[HTTP ERROR: 12029 : 
ERROR_WINHTTP_CANNOT_CONNECT]LOG]!><time="09:01:57.193+360" date="01-07-2004" 
component="CCMEXEC" context="" type="1" thread="764" file="ccmhttperror.cpp:73">
<![LOG[Request failed: 404 Object Not Found]LOG]!>

CAUSE

This problem may occur if one or more of the following conditions are true:
  • The SMS 2003 server locator point (SLP) has not been enabled.
  • The URLscan filter that is contained in the Internet Information Services (IIS) Lockdown Tool is installed on a Windows 2000-based computer that is acting as the SMS 2003 management point.
  • The SMS 2003 management point is installed on a Windows Server 2003-based computer, and the SMS 2003 management point has stopped responding.

WORKAROUND

Windows 2000 management point

To work around this problem, enable an SMS 2003 SLP, and then remove the URLscan filter from the Windows 2000-based computer that is acting as an SMS 2003 management point. To do this, follow these steps.

Enable the SLP

  1. Click Start, point to Programs, point to Systems Management Server, and then click SMS Administrator Console.
  2. In the SMS Administrator Console, expand Site Database, expand Site Hierarchy, expand SiteCode-SiteName, expand Site Settings, click Site Systems, right-click the server that is acting as the management point, and then click Properties.
  3. In the \\ServerName Site Systems Properties dialog box, click the Server Locator Point tab, and then click the Use this site system as a server locator point check box.
  4. In the list that is next to Database, you can select to use the site database or select another database. Make your selection, and then click OK.

Remove the UrlScan filter from a Windows 2000-based computer


Warning This workaround may make your computer or your network more vulnerable to attack by malicious users or by malicious software such as viruses. We do not recommend this workaround but are providing this information so that you can implement this workaround at your own discretion. Use this workaround at your own risk.
Note URLScan is an Internet Server API (ISAPI) filter that screens and monitors HTTP requests for Internet Information Server 4.0, Internet Information Services 5.0, and Internet Information Services 5.1. URLScan helps reduce the exposure of IIS to potential Internet attacks.
  1. Click Start, point to Programs, point to Administrative Tools, and then click Internet Services Manager.
  2. In the Internet Services Manager snap-in, right-click the server that you want to modify, and then click Properties.
  3. In the ServerName Properties dialog box, next to Master Properties, click Edit.
  4. In the WWW Master Properties for ServerName dialog box, click the ISAPI Filters tab.
  5. Click UrlScan, click Remove, and then click OK two times.

Windows Server 2003 management point

To work around this problem, remove the Management point and the IIS component, and then re-install the Management Point and the IIS component on the Windows Server 2003-based computer. To do this, follow these steps:
  1. Click Start, point to Programs, point to Systems Management Server, and then click SMS Administrator Console.
  2. In the SMS Administrator Console, expand Site Database, expand Site Hierarchy, expand SiteCode-SiteName, expand Site Settings, click Site Systems, right-click the server that is acting as the management point, and then click Properties.
  3. In the \\ServerName Site Systems Properties dialog box, click the Management Point tab, and then click to clear the Use this site system as a management point check box.
  4. Click Start, click Control Panel, double-click Add or Remove Programs, click Add/Remove Windows Components, and then click Application Server.
  5. Click to clear the Internet Information Services (IIS) check box.
  6. Restart the Windows Server 2003-based computer.
  7. After the Windows Server 2003-based computer restarts, click Start, click Control Panel, double-click Add or Remove Programs, click Add/Remove Windows Components, and then click Application Server.
  8. Click to select the Internet Information Services (IIS) check box.
  9. Click Start, point to Programs, point to Systems Management Server, and then click SMS Administrator Console.
  10. In the SMS Administrator Console, expand Site Database, expand Site Hierarchy, expand SiteCode-SiteName, expand Site Settings, click Site Systems, right-click the server that is acting as the management point, and then click Properties.
  11. In the \\ServerName Site Systems Properties dialog box, click the Management Point tab, and then click to select the Use this site system as a management point check box.
  12. In the list that is next to Database, you can select to use the site database, or you can select another database.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:6/13/2005
Keywords:kbtshoot kbprb KB883983 kbAudITPRO