You cannot update compressed package source files that reside on a System Management Server 2.0 child site (883982)



The information in this article applies to:

  • Microsoft Systems Management Server 2.0

SYMPTOMS

When you try to update compressed package source files that reside on a System Management Server 2.0 (SMS 2.0) child site, the updated package source files are not updated.
Additionally, the C:\SMS\Logs\Distrmg.log file may contain many error messages that are similar to the following:
Package PackageID requires a newer version (4) of source files and the new compressed files hasn't arrived yet, current version is 3, skip F:\SMS\inboxes\distmgr.box\INCOMING\Packagename.PKG $$<SMS_DISTRIBUTION_MANAGER><Thu Feb 14 7:28:06.277 2002 Eastern Standard Time><thread=1540 (0x604)> Processing incoming file F:\SMS\inboxes\distmgr.box\INCOMING\Packagename.PKG.

CAUSE

This problem occurs when the SMS 2.0 Distribution Manager component continually tries to decompress the original package on the distribution point in the SMS 2.0 child site.

By default, the SMS 2.0 Distribution Manager is configured to retry package decompression 100 times every 30 minutes for a failed package.

Depending on the number of SMS 2.0 child sites that experience this problem and the number of compressed packages at the child sites that require the updated version, the SMS 2.0 site may experience very high status message processing utilization. In this case, you may not be able to update the compressed package on a child site even when you try to manually update the distribution point.

WORKAROUND

To work around this problem, remove the distribution point from the child site server that is experiencing this problem. To do this, follow these steps:
  1. Click Start, point to Programs, point to Systems Management Server, and then click SMS Administrator Console.
  2. In the SMS Administrator Console, expand Site Database, expand Site Hierarchy, expand SiteCode-SiteName, expand Site Settings, and then expand Site Systems.
  3. Under Site Systems, right-click the computer that is experiencing the problem, and then click Properties.
  4. On the Distribution Point tab, click to clear the Use this site system as a distribution point check box, and then click OK.
  5. After you remove the distribution point, make sure that the the\SMS\Inboxes\DistMgr.box folder and its sub-folders do not contain any .pkg files. If any .pkg files are present, delete them manually.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:6/13/2005
Keywords:kbtshoot kbprb KB883982 kbAudITPRO