You cannot install Advanced Client when your Systems Management Server 2003 does not use Active Directory or when the schema for Active Directory has not been extended (883620)



The information in this article applies to:

  • Microsoft Systems Management Server 2003

SYMPTOMS

You cannot install the Microsoft Systems Management Server (SMS) 2003 Advanced Client on client computers when your SMS 2003 site does not use Active Directory or when the schema for Active Directory has not been extended for SMS 2003.

On an Advanced Client computer, the %Windir%\System32\CCM\Logs\Clientlocation.log file may contain entries that are similar to the following:Date Time Autodiscover Site SiteName (HexValue)Date Time Current AD site of machine is Default-First-Site-Name SiteName (HexValue)Date Time

Attempting to retrieve SLPs from AD SiteName (HexValue)Date Time Failed to resolve IP address from WINS sitename (hexvalue)Date Time LSGetSLP : Failed to resolve SLP from WINS, is it published SiteName (HexValue)Date Time LSGetAssignedSiteFromSLP : Unable to get the list of SLPs SiteName (HexValue)

CAUSE

This issue occurs when the Advanced Client cannot locate a server locator point (SLP). The Advanced Client may experience this issue when either of the following conditions is true:
  • The Active Directory schema is not extended.
  • The SMS site is in a Microsoft Windows NT 4.0 domain.

RESOLUTION

To resolve this issue, manually add an SMS_SLP record and an SMS_MP record to the Windows Internet Name Service (WINS) database. To do this, use one of the following methods, depending on the operating system that you are running:

Windows Server 2003 and Windows 2000

To manually add the SMS_SLP and SMS_MP records to WINS in Microsoft Windows Server 2003 and in Microsoft Windows 2000, follow these steps:
  1. Click Start, click Run, type cmd, and then click OK.
  2. Type the following commands at the command prompt, and then press ENTER after each command:
    • netsh
    • wins
    • server
  3. Add the SMS_SLP record. To do this, type the following command, and then press ENTER:

    add name name=SMS_SLP endchar=1A rectype=0 ip={ip addresses}

    Note Make sure that you enclose the IP address in braces ("{ }").
  4. Add the MP_SMSSiteCode record. To do this, type the following command, and then press ENTER:

    add name name=MP_SMSSiteCode endchar=1A rectype=0 ip={ip addresses}

    Note Make sure that you enclose the IP address in braces ("{ }"). The SMSSiteCode variable represents the three-character string (letters, integers, or a combination of both) that is the code for the SMS site to which the Management Point belongs. It is displayed in the SMS Administrator Console.

Windows NT 4.0

Use the WINS Manager

To manually add WINS records in Windows NT 4.0 by using the WINS Manager, follow these steps:
  1. Click Start, point to Programs, point to Administrative Tools (Common), and then click WINS Manager.
  2. Click the WINS server in the list of WINS Servers.
  3. Click Mappings, and then click Static Mappings.
  4. Click Add Mappings.
  5. In the Name box, type SMS_SLP[1Ah].
  6. In the IP Address box, type the IP address of the SLP.
  7. Click Unique under Type, click Close two times, and then exit the WINS Manager.
  8. Add the MP_SMSSiteCode record. To do this, repeat steps 1 to 7, replacing SMS_SLP[1Ah] with MP_SMSSiteCode[1Ah] in step 5.

    Note The SMSSiteCode variable represents the three-character string (letters, integers, or a combination of both) that is the code for the SMS site to which the Management Point belongs.

Use the Winscl.exe tool

To manually add WINS records at a command prompt in Microsoft Windows NT 4.0, use the Winscl.exe tool. The Winscl.exe tool is included in the Microsoft Windows NT 4.0 Resource Kit Support Tools. By default, the Winscls.exe file is installed to the Drive:\Program Files\Rksupport folder. To use Winscl.exe, follow these steps:
  1. Click Start, click Run, type cmd in the Open box, and then click OK.
  2. Change to the folder where Winscl.exe is installed. Typically, this folder is the Drive:\Program Files\Rksupport folder.
  3. Type 1 to connect by TCP/IP.
  4. Type the IP address of the WINS server.
  5. Type RN to register a name.
  6. Type SMS_SLP to register the name of the SLP.
  7. Type 1 to add a sixteenth character to the SMS_SLP WINS record.
  8. Type 1A as the sixteenth character.
  9. Type 0 for no scope.
  10. Type 3 to make the SMS_SLP record multihomed.
  11. Type 1 for the number of addresses to input.
  12. Type the IP address of the SLP.
  13. Type 1 to set this record as an h-node.
  14. Type EX to exit Winscl.exe.
  15. Add the SMS_MP record. To do this, repeat steps 1 through 14, replacing SMS_SLP with MP_SMSSiteCode in step 6.

    Note The SMSSiteCode variable represents the three-character string (letters, integers, or a combination of both) that is the code for the SMS site to which the Management Point belongs.

MORE INFORMATION

The SLP locates client access points (CAPs) for Legacy Clients and management points for Advanced Clients at client logon time. The SLP replaces the SMS 2.0 logon point and eliminates most traffic between SMS and domain controllers.

The Advanced Client communicates with SMS sites by using management points. Management points provide Advanced Clients with configuration details and advertisements. They also receive inventory, software metering, and client status information.

If the Advanced Client cannot locate a SLP or management point by querying the Active Directory, the Advanced Client will look for this information by querying a WINS server. SMS 2003 does not create SLP or management point records in WINS. These entries must be created manually for sites that do not have an extended Active Directory schema. After you add the SLP and management point records to WINS, the Advanced Client will be able to find a SLP, and then the Advanced Client can continue the installation of SMS client components.

For additional information about planning and deploying SMS 2003, visit the following Microsoft Web site: For more information about using the Winscl.exe Windows NT 4.0 Resource Kit Support Tools utility, click the following article number to view the article in the Microsoft Knowledge Base:

137582 Using Wincl.exe

For more information about using Netsh.exe to add an entry to a Windows 2000 WINS database, click the following article number to view the article in the Microsoft Knowledge Base:

233375 How to manually add a dynamic WINS entry to a Windows 2000 WINS server

To obtain the Windows NT 4.0 Resource Kit Support Tools, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:6/13/2005
Keywords:kbprb kbtshoot kbwinservperf kbMgmtServices KB883620 kbAudITPRO