Your USB printer may become unavailable when it is connected to a Windows 2000-based computer (883528)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Advanced Server

SYMPTOMS

Your universal serial bus (USB) printer that is connected to your Microsoft Windows 2000-based computer may unexpectedly become unavailable. If you unplug the USB printer cable from your computer and then plug it back in, the printer becomes available again.

CAUSE

This problem may occur when there is a single communication failure between the computer and the USB printer. The USB printing component for Windows 2000 does not have a recovery feature for USB transfer errors such as a cyclic redundancy check (CRC) error. Most USB client device drivers have a recovery feature that resets the communication between the USB device and a Windows 2000-based computer when a USB transfer error occurs.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   -----------------------------------------------------------
   17-Aug-2004  05:35  5.0.2195.6968      22,832  Usbprint.sys   

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:

816915 New file naming schema for Microsoft Windows software update packages

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbBug kbfix kbWin2000preSP5fix kbHotfixServer kbQFE KB883528 kbAudEndUser kbAudITPRO