Your Windows 2000-based computer stops responding and displays a blank screen after a restart (883491)



The information in this article applies to:

  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional

SYMPTOMS

After you restart your Microsoft Windows 2000-based computer, your computer stops responding and your computer displays a blank screen. This symptom occurs if the following conditions are true:
  • Your computer has an AGP video adaptor.
  • Your computer has a VIA chip set.
The blank screen is displayed after the Windows startup screen appears, but before the desktop appears.

CAUSE

This problem occurs because the Viaagp.sys video adaptor driver does not correctly initialize the memory in the Graphic Address Relocation Table (GART). The incorrect initialization of memory may make the video adaptor driver try to access an invalid physical address. When the video adaptor driver tries to access an invalid physical address, the computer stops responding.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have Microsoft Windows 2000 Service Pack 3 (SP3) or later versions installed on your computer before you apply this hotfix.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size    File name
   -----------------------------------------------------
   02-Aug-2004  18:20  5.0.2195.6961  22,416  Viaagp.sys
To apply this hotfix, follow these steps:
  1. Download the hotfix file to a folder on your hard disk.
  2. Unzip the file to the root folder of drive C.
  3. Restart your computer in Safe mode.
  4. At a command prompt, type c:, and then press ENTER.
  5. At a command prompt, type cd \winnt\system32\drivers, and then press ENTER.
  6. At a command prompt, type ren viaagp.sys viaagp.old, and then press ENTER.
  7. At a command prompt, type copy c:\viaagp.sys, and then press ENTER.
  8. Restart your computer.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:

816915 New file naming schema for Microsoft Windows software update packages

For additional information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbBug kbfix kbWin2000preSP5fix kbHotfixServer kbQFE KB883491 kbAudITPRO