The Find Computers tool in the Active Directory Users and Computers snap-in incorrectly lists a computer as a domain controller in the search results (883480)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

You use the Active Directory Users and Computers snap-in to set the Trust this computer for delegation setting on a computer account to let that computer be trusted for delegation. When you use the Find Computers tool in the Active Directory Users and Computers snap-in to search for that computer, the computer is returned in the search results as expected. However, the computer is incorrectly listed as a Domain Controller in the Machine Role column. If you click Domain Controller in the Role box, and then click Find Now to filter the search results to display only domain controllers, the computer is no longer listed in the search results.

CAUSE

This problem occurs because the Find Computers tool incorrectly processes whether the UserAccountControl attribute of the computer object that is in Active Directory includes the UF_SERVER_TRUST_ACCOUNT flag.

RESOLUTION

Windows Server 2003 hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel. Windows Server 2003, 32-bit editions
  Date         Time   Version       Size     File name
  ------------------------------------------------------
  13-Sep-2004  21:10  5.2.3790.210  240,128  Dsquery.dll 
Windows Server 2003, 64-bit edition
  Date         Time   Version       Size     File name     Platform
  -----------------------------------------------------------------
  13-Sep-2004  21:04  5.2.3790.210  478,208  Dsquery.dll   IA-64
  13-Sep-2004  21:10  5.2.3790.210  240,128  Wdsquery.dll  x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies To" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbBug kbfix kbWinServ2003preSP1fix KB883480 kbAudEndUser kbAudDeveloper kbAudITPRO kbAudOEM