You receive an "Invalid page fault in module Tps108.dll" error message or an "Internet Explorer has encountered a problem and needs to close" error message when you start Internet Explorer (883318)



The information in this article applies to:

  • Microsoft Internet Explorer 6.0, when used with:
    • the operating system: Microsoft Windows XP
    • the operating system: Microsoft Windows 2000
    • the operating system: Microsoft Windows Millennium Edition
    • the operating system: Microsoft Windows 98 Second Edition
    • the operating system: Microsoft Windows 98

SYMPTOMS

When you start Microsoft Internet Explorer, Internet Explorer quits unexpectedly and you receive an error message that is similar to one of the following:
Iexplore caused an invalid page fault in module Tps108.dll
Internet Explorer has encountered a problem and needs to close. We are sorry for the inconvenience.
If you view the contents of the error report that is contained in this error message, the error report contains an error signature that is similar to the following:

AppName       AppVer          ModName     ModVer         Offset 
iexplore.exe  ProgramVersion  tps108.dll  ModuleVersion  Offset

Additionally, when you try to open My Computer or Microsoft Windows Explorer, you may receive an error message that is similar to the following:
Explorer has caused an Invalid Page Fault in module Tps108.dll

CAUSE

This issue may occur if the third-party Tps108.dll program is installed on your computer, and if the Tps108.dll program is preventing Internet Explorer and Windows Explorer from working correctly.

RESOLUTION

To resolve this issue, use one of the following methods.

Method 1: Turn off the "Enable third-party browser extensions (requires restart)" option in Internet Explorer

  1. Start Internet Explorer if it is not already started.
  2. On the Tools menu, click Internet Options, and then click the Advanced tab.
  3. In the Settings box under Browsing, click to clear the Enable third-party browser extensions (requires restart) check box, and then click OK.
  4. Quit and then restart Internet Explorer.
For additional information about the "Enable third-party browser extensions (requires restart)" option, click the following article number to view the article in the Microsoft Knowledge Base:

298931 How to disable third-party tool bands and Browser Helper Objects

Method 2: Disable the Tps108.dll program on your computer

To disable the Tps108.dll program, locate the Tps108.dll file on your computer, and then unregister the Tps108.dll file. To do this, follow these steps:
  1. Click Start, and then click Search.
  2. Click All files and folders.
  3. In the All or part of the file name box, type tps108.dll, and then click Search.
  4. Make a note of the path of the Tps108.dll file on your hard disk.
  5. Click Start, click Run, type cmd in the Open box, and then press ENTER.
  6. At the command prompt, type the following line, where Path is the path of the Tps108.dll file on your hard disk, and then press ENTER:

    regsvr32 /u Path\tps108.dll

    For example, if the Tps108.dll file is located in the C:\Windows folder, type the following line, and then press ENTER:

    regsvr32 /u c:\windows\tps108.dll

  7. When you receive the message that states that the operation succeeded, click OK.
  8. Shut down, and then restart your computer.

Method 3: Remove the Tps108.dll program from your computer

Note Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.
  1. Use the Add or Remove Programs tool to remove the Tps108.dll program from your computer. To do this, follow these steps:
    1. Click Start, click Run, type appwiz.cpl in the Open box, and then click OK.
    2. In the list of currently installed programs, click TPS108 if the program is listed, and then click Remove.

      Note If the TPS108.dll program is not listed in the Add or Remove Programs tool, go to step 2.
  2. Unregister the Tps108.dll file. To do this, follow the steps in the "Method 2: Disable the Tps108.dll program on your computer" section.
  3. End the Preinsttps108.exe process if the process is running. To do this, follow these steps:
    1. Right-click an empty area of the Windows task bar, and then click Task Manager.
    2. Click the Processes tab.
    3. In the list of processes, click Preinsttps108.exe, and then click End Process.
    4. Quit Task Manager.
  4. Delete the following registry subkeys if the registry subkeys exist in the Windows registry:
    • HKEY_CLASSES_ROOT\CLSID\{50a28604-52f2-11d6-8f0f-5254ab11d5c2}
    • HKEY_CLASSES_ROOT\Tps108.tps108obj.1
    • HKEY_LOCAL_MACHINE\Software\Classes\tps108.tps108obj.1
    • HKEY_LOCAL_MACHINE\Software\Software\tps108
    • HKEY_LOCAL_MACHINE\Software\Tps108
    To delete these registry subkeys, follow these steps.
    Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
    1. Click Start, click Run, type regedit in the Open box, and then click OK.
    2. Locate and then click the registry subkey that you want to delete.
    3. On the Edit menu, click Delete.
    4. When you are prompted to confirm the deletion, click Yes.
  5. Locate and then delete the following files from your hard disk if the files exist on your hard disk:
    • Preinsttps108.exe
    • Tps108.dll

MORE INFORMATION

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MinorLast Reviewed:9/14/2006
Keywords:kberrmsg kbprb kbtshoot KB883318 kbAudITPRO kbAudEndUser