"FrontPage Error" error message when you try to upload a document to a SharePoint Team Services Web site on a computer that is running Windows XP Service Pack 2 (883315)



The information in this article applies to:

  • SharePoint Team Services from Microsoft

SYMPTOMS

When you try to upload a document to a document library in a SharePoint Team Services from Microsoft Web site and SharePoint Team Services is installed on a computer that is running a slipstream version of Microsoft Windows XP Service Pack 2 (SP2), you may receive the following error message:

FrontPage Error.

User: Please report details to this site's webmaster.

Webmaster: Please see the server's application event log for more details.
Note A slipstream version of Windows XP SP2 is a version of Windows XP SP2 that is integrated with the Windows XP installation media. For example, you experience this behavior after you install SharePoint Team Services on a computer that is running the slipstream version of Windows XP SP2. You do not experience this behavior if you upgrade a computer that is running Windows XP to Windows XP SP2, and then install SharePoint Team Services.

CAUSE

This behavior occurs because of the following changes that are made to Microsoft Internet Information Services (IIS) in Windows XP SP2:
  • The Internet Guest account (IUSR_ComputerName) is denied permissions to the following folder:

    Drive:\Inetpub\Wwwroot

  • Integrated Windows authentication is turned off.

RESOLUTION

To resolve this behavior, follow these steps:
  1. Turn on Integrated Windows authentication for the Web site in IIS. To do this, follow these steps:
    1. Click Start, click Run, type control admintools in the Open box, and then click OK.
    2. Double-click Internet Information Services.
    3. Expand ComputerName, and then expand Web Sites.
    4. Right-click Default Web Site, and then click Properties.
    5. Click the Directory Security tab.
    6. Under Anonymous access and authentication control, click Edit.
    7. In the Authentication Methods dialog box, click to select the Integrated Windows authentication check box, and then click OK two times.
  2. Remove the Deny permissions that are configured for the Internet Guest account (IUSR_ComputerName) on the Drive:\Inetpub\Wwwroot folder. To do this, follow these steps:
    1. Start Microsoft Windows Explorer, and then locate the following folder:

      Drive:\Inetpub\Wwwroot

    2. Right-click the Wwwroot folder, and then click Properties.
    3. Click the Security tab.

      Note If the Security tab is not displayed, click Folder Options on the Tools menu, and then click the View tab. In the Advanced settings box, click to clear the Use simple file sharing (Recommended) check box, and then click OK.
    4. Click Advanced, and then click the Permissions tab.
    5. Click the Deny entry that is listed next to Internet Guest Account, click Remove, click to select the Replace permission entries on all child objects with entries shown here that apply to child objects check box, and then click OK.
    6. If you are prompted to continue, click Yes.
    7. Click OK.
  3. Configure SharePoint Team Services to reapply the permissions that you configured for the Drive:\Inetpub\Wwwroot folder. To do this, follow these steps:
    1. Connect to your SharePoint Team Services Web site, and then click Site Settings.
    2. On the Site Settings page, under Web Administration, click Go to Site Administration.
    3. On the Site Administration for SiteName page, under Server Health, click Check server health.
    4. On the Check Server Health page, click to select the Repair check box that is next to Reapply file security settings, and then click OK.

MORE INFORMATION

For more information about Windows XP SP2, visit the following Microsoft Web site: For more information about how to configure and how to administer SharePoint Team Services, see the SharePoint Team Services product documentation. To do this, visit the following Microsoft Web site:

Modification Type:MajorLast Reviewed:8/21/2004
Keywords:kbConfig kbpermissions kberrmsg kbtshoot KB883315 kbAudITPRO