"Unable to connect to metabase" error message when you try to install Windows 2000 Service Pack 4 (883281)



The information in this article applies to:

  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Server

SYMPTOMS

When you try to install Windows 2000 Service Pack 4 (SP4), the installation is not completed successfully, and you receive the following error message:
Unable to connect to metabase

CAUSE

This issue may occur when Microsoft Internet Information Services (IIS) is installed on your computer, and the IIS Admin Service interferes with the service pack installation.

RESOLUTION

To resolve this issue, use method 1. If method 1 does not resolve the issue, use method 2.

Method 1: Stop the IIS Admin Service, and then install Windows 2000 SP4

Stop the IIS service

To stop the IIS service, follow these steps:
  1. Click Start, click Run, type services.msc, and then press ENTER.
  2. In Services, right-click IIS Admin Service in the details pane, and then click Stop.
  3. In Stop Other Services, click Yes to confirm that you want to stop the services that depend on IIS.

Install Windows 2000 SP4

For information about how to download and install Windows 2000 SP4, visit the following Microsoft Web site:

Method 2: Remove IIS from your computer, install Windows 2000 SP4, and then reinstall IIS

Note To remove IIS from you computer, back up the metabase and then restore it after you reinstall IIS. If you do not back up the metabase and then restore it, you will lose Web site configurations and you will have to re-create them.

Back up the metabase

To back up the metabase, follow these steps:
  1. Click Start, click Programs, point to Administrative Tools, and then click Internet Services Manager.
  2. Right-click Computer Name, and then click Backup/Restore Configuration.
  3. Click Create backup, and then type a name for the backup file. Add a password if you want to.

    Note It is a good idea to include the date in the backup file name. For example, type 12-07-04Backup.
  4. Click OK to create the backup file.

    The backup file is created in the %SystemRoot%\Winnt\System32\Inetsrv\MetaBack folder.

    Note It is a good idea to copy this backup file to another location because you may have to restore it later.

Remove IIS from your computer

To remove IIS from your computer, follow these steps:
  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click Add/Remove Programs.
  3. In the left pane, click Add/Remove Windows Components.
  4. Click Internet Information Services (IIS), and then click Details.

    Note Do not click to clear the check box yet.
  5. Write down the components that are currently installed.
  6. Click OK.
  7. In the Windows Components Wizard, click to clear the Internet Information Services (IIS) check box, and then click Next.
  8. When the remove operation is completed, click Finish.

Install Windows 2000 SP4

For information about how to download and install Windows 2000 SP4, visit the following Microsoft Web site:

Install IIS again

To install IIS, follow these steps:
  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click Add/Remove Programs.
  3. In the left pane, click Add/Remove Windows Components.
  4. In the Windows Components Wizard, click to select the Internet Information Services (IIS) check box, and then click Details.
  5. Make sure that the components that you wrote down in step 5 of the "Remove IIS from your computer" procedure are selected.
  6. Click OK.
  7. Click Next.

    Note If you are prompted to insert your Windows 2000 Server CD, follow these steps:
    1. Click OK, and then insert your Windows 2000 Server CD.
    2. Click Browse and then locate the I386 folder on your Windows 2000 Server CD.
    3. Click Open, and then click OK in the Files Needed dialog box.
  8. When the install operation is completed, click Finish.

Restore the metabase

To restore the metabase, follow these steps:
  1. Click Start, click Programs, point to Administrative Tools, and then click Internet Services Manager.
  2. Right-click Computer Name, and then click Backup/Restore Configuration.

    Note You may have to restore the .mdo file that you previously created to the %SystemRoot%\Winnt\System32\Inetsrv\MetaBack folder.
  3. Click to select the backup file name in the Backups list box.
  4. Click Restore, enter the password if you must, and then click Yes.
  5. Click OK.
  6. Click Close.

Modification Type:MinorLast Reviewed:9/8/2006
Keywords:kbtshoot kbprb KB883281 kbAudITPRO