Virtual Server 2005 virtual machines cannot contact the Automated Deployment Services controller during the Pre-Boot Execution Environment startup process (875533)



The information in this article applies to:

  • Microsoft Virtual Server 2005, when used with:
    • the operating system: Microsoft Windows Server 2003, 64-Bit Enterprise Edition
    • the operating system: Microsoft Windows Server 2003, Enterprise Edition
    • the operating system: Microsoft Windows Server 2003, Standard Edition
    • the operating system: Microsoft Windows Server 2003, Web Edition

SYMPTOMS

When you use Automated Deployment Services (ADS) in a Microsoft Virtual Server virtual machine during a Pre-Boot Execution Environment (PXE) startup process, you may experience the following behavior:
  • Client computers cannot contact the Microsoft Windows Server 2003 ADS controller.
  • Client computers do not receive a PXE response from the ADS controller.

CAUSE

This problem may occur when the DHCP client (Bmdhcp.exe) that is included in the ADS Deployment agent queries the PXE network adaptor GUID, and the GUID information is not yet available for the PXE network adaptor. In this case, the DHCP client stops and does not connect to the ADS controller.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Virtual Server service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   05-Aug-2004  20:10  5.2.3571.1004      30,208  Bmdhcp.exe       

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbVirtualSrv05preSP1fix kbBug kbfix KB875533 kbAudITPRO