The Diskpart utility or the Cluster Administrator may take many seconds to process a task on a computer that is running Windows Server 2003 (875524)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

You may experience the following symptoms when you use the Diskpart utility or the Cluster Administrator on a computer that is running Microsoft Windows Server 2003.

Symptom 1

When you run the Diskpart utility, and you use the rescan command, the operation that is performed by the rescan command may take longer than expected to complete. Additionally, the following Error event is logged in the system log:Event Type: Error
Event Source: Virtual Disk Service
Event Category: None
Event ID: 1
User: N/A
Computer: Computer name
Description: Unexpected Failure

Symptom 2

  1. You run Cluster Administrator.
  2. You create a new resource group.
  3. You create a new resource in the new resource group.
  4. On the New Resource page, you click Physical Disk in the Resource Type list.
  5. You have to wait many seconds before the Possible Owners page opens.

CAUSE

These problems may occur because some hard disk drivers return information in an unexpected format. When the information that the hard disk drivers return is not in the expected format, you must wait for the operating system to consolidate the conflicting information that the hard disk drivers returned.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.Windows Server 2003, 32-Bit versions
File nameFile versionFile sizeDateTimePlatformService branch
Classpnp.sys5.2.3790.19661,95203-Aug-200401:06x86RTMQFE
Windows Server 2003, IA-64 versions
File nameFile versionFile sizeDateTimePlatformService branch
Classpnp.sys5.2.3790.196145,40803-Aug-200401:53IA-64RTMQFE

Alternative to the hotfix

You may be able to obtain an updated driver for the hard disk controller from the manufacturer of your hardware. Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information. For information about how to contact your hardware manufacturer, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

65416 Hardware and software vendor contact information, A-K

60781 Hardware and software vendor contact information, L-P

60782 Hardware and software vendor contact information, Q-Z

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbBug kbfix kbWinServ2003preSP1fix KB875524 kbAudITPRO