Third-party fax program cannot send faxes in Microsoft Small Business Server 2003 (875432)



The information in this article applies to:

  • Microsoft Windows Small Business Server 2003, Premium Edition
  • Microsoft Windows Small Business Server 2003, Standard Edition

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

After you install a third-party fax program to use with Microsoft Exchange in Microsoft Small Business Server (SBS) 2003, faxes from clients are not sent, and the fax software does not report an error.

CAUSE

This problem occurs because the Microsoft Exchange MTA Stacks service and functionality is turned off. By default, SBS 2003 disables the MTA Stacks service and functionality. Some third-party programs install an Exchange connector that requires the MTA Stacks service to work correctly. Manually starting the MTA Stacks service may not resolve the problem.

RESOLUTION

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.To resolve this problem, you must modify the registry to enable the MTA functionality. Before you start these steps, make sure that you have a good working system state backup. To resolve this problem, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate the following registry sub key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\name of your Exchange server computer\Private-guid_of_private_mdb

  3. Delete the following two registry values:
    • Gateway In Threads
    • Gateway Out Threads
  4. Locate the following registry sub key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\name of your Exchange server computer\Public-guid_of_public_mdb

  5. Delete the following two registry values:
    • Gateway In Threads
    • Gateway Out Threads
  6. Quit Registry Editor.
  7. Click Start, point to Administrative Tools, and then click Services.
  8. Right-click Microsoft Exchange MTA Stacks, and then click Properties.
  9. On the General tab, change the startup type to automatic, click Apply, and then click OK.
  10. Right-click Microsoft Exchange MTA Stacks, and then click Start.
  11. Right-click Microsoft Exchange System Attendant, and then click Restart. This procedure also restarts all dependant services.
  12. Restart any services that were installed by the third-party fax product.
  13. Quit the Services snap-in.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

This problem has been reported to occur with the following third-party products:
  • GFI Faxmaker 10
  • Fenestrae Fax Connector 5.0
  • Lightning Fax
  • Fax Sr
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products. For information about how to contact a third-party vendor, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

65416 Hardware and software vendor contact information, A-K

60781 Hardware and software vendor contact information, L-P

60782 Hardware and software vendor contact information, Q-Z


Modification Type:MajorLast Reviewed:7/31/2006
Keywords:kbService kbClient kbPerformance kbinterop kbtshoot KB875432 kbAudITPRO