An Exchange Server 2003 computer that is configured as a public folder server may experience very poor performance (873415)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry



For a Microsoft Exchange 2000 Server version of this article, see 841645.

SYMPTOMS

A Microsoft Exchange Server 2003 computer that is configured as a public folder server may experience very poor performance. When this problem occurs, one or more of the following problems may occur:
  • Users are prompted to enter their Exchange credentials again.
  • E-mail functionality slows.
  • Users may lose their connection to the Exchange computer.
  • Microsoft Outlook Address Book downloads may take longer than expected.

CAUSE

This problem may occur when slow domain controller responses cause a backlog of requests to reload the public folder hierarchy in the Microsoft Exchange Information Store service (Store.exe). The hierarchy should only be reloaded one time during an interval of time that is defined. This interval is typically 15 minutes. The symptoms that are described in this article occur because the time-out expires, and each client thread tries to reload the hierarchy.

The time-out value is not reset until the client thread receives a Lightweight Directory Access Protocol (LDAP) response from a domain controller. The response must contain the list of public folder servers. When the client thread receives the response, each client thread issues an LDAP request. If there are many users on your network, these LDAP requests could exhaust the 100 remote procedure call (RPC) requests that can be open at a time.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Exchange Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

This hotfix requires Microsoft Exchange Server 2003 Service Pack 1.

Restart requirement

You do not have to restart your computer after you install this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Date         Time   Version            Size    File name
--------------------------------------------------------------
23-Nov-2004  00:46  6.5.7232.55     3,261,952  Mdbmsg.dll       
23-Nov-2004  01:19  6.5.7232.55     5,143,552  Store.exe

WORKAROUND

If you apply the hotfix that is described in this article, you do not have to use this workaround. To work around this problem, configure the replication reload value to a 24-hour interval in the registry.

To configure the replication reload value in the registry, follow these steps.

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.
  1. Click Start, click Run, type regedt32 in the Open box, and then click OK.
  2. Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MsExchangeIS\<ServerName>\Public-(guid)

  3. On the Edit menu, click Add Value.
  4. In the Value Name box, type the following:

    Replication Reload TLH Min

  5. In the Data Type list, click REG_DWORD, and then click OK.
  6. In the Data box, type 86400, and then click OK.

    Note The value is the number of seconds between reloads. 86,400 seconds is equal to 24 hours.
  7. Exit Registry Editor.
The replication value that you specify is only read when the public folder store starts. To force your Exchange Server 2003 computer to read the new value, dismount and then mount the public folder store. Do this after work hours when the load on the system is very light.

To dismount and then mount the public folder store, follow these steps:
  1. Start Exchange System Manager.
  2. Expand Servers, expand the server that you want, expand Storage_Group_Name, and then right-click Public Folder Store.

    Note If administrative groups are defined, follow these steps:
    1. Expand Administrative Groups.
    2. Expand Administrative_Group_Name.
    3. Expand Servers.
    4. Expand the server that you want.
    5. Expand Storage_Group_Name.
    6. Right-click Public Folder Store.
  3. Click Dismount Store, and then click Yes to continue.
  4. Right-click Public Folder Store, click Mount Store, and then click OK.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

817903 New naming schema for Exchange Server software update packages


Modification Type:MajorLast Reviewed:4/7/2006
Keywords:kbQFE KBHotfixServer kbfix kbBug kbExchange2003preSP1fix KB873415