Many RPC calls to a global catalog occur in a distributed Windows Server 2003 environment (873406)



The information in this article applies to:

  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Datacenter Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Datacenter Edition

SYMPTOMS

When you deploy the Active Directory directory service in a distributed Microsoft Windows Server 2003 environment, you may experience heavy network traffic over the remote links. This problem occurs when the following conditions are true:
  • You have many remote sites.
  • Each site has a domain controller but no global catalog.
Typically, you may notice many remote procedure calls (RPC) to the global catalog over the remote link.

CAUSE

This problem occurs when the Windows Management Instrumentation (WMI) Windows NT event log provider uses a random GUID on a directory services call. When the Windows NT event log provider has to convert a GUID, the Windows NT event log provider calls the DsCrackNames function. If the DsCrackNames function cannot convert the GUID, the DsCrackNames function contacts the global catalog.

Note The DsCrackNames function converts an array of directory service object names from one format to another format.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel. Windows Server 2003, 32-bit versions

Date         Time   Version            Size    File name
--------------------------------------------------------------
03-Aug-2004  15:24  5.2.3790.196      228,864  Ntevt.dll

Windows Server 2003, 64-bit versions

Date         Time   Version           Size     File name   Platform
--------------------------------------------------------------------
03-Aug-2004  14:25  5.2.3790.196      671,744  Ntevt.dll   IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about Active Directory in Windows Server 2003, visit the following Microsoft Web site: For additional information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbWinServ2003preSP1fix kbfix kbBug kbprb KB873406 kbAudITPRO