How to troubleshoot problems with investment quotes (873204)



The information in this article applies to:

  • Microsoft Money 2007 Deluxe
  • Microsoft Money 2007 Home & Business
  • Microsoft Money 2007 Premium
  • Microsoft Money Deluxe 2006
  • Microsoft Money Premium 2006
  • Microsoft Money Small Business 2006
  • Microsoft Money Standard 2006
  • Microsoft Money 2005 Deluxe
  • Microsoft Money 2005 Premium
  • Microsoft Money 2005 Small Business
  • Microsoft Money 2005 Standard
  • Microsoft Money 2004 Deluxe
  • Microsoft Money 2004 Premium
  • Microsoft Money 2004 Small Business
  • Microsoft Money 2004 Standard
  • Microsoft Money 2003 Deluxe
  • Microsoft Money 2003 Deluxe and Business
  • Microsoft Money 2003 Standard
  • Microsoft Money 2002
  • Microsoft Money 2002 Deluxe and Business Edition
  • Microsoft Money 2002 Deluxe Edition
  • Microsoft Money 2001
  • Microsoft Money 2001 Deluxe and Business
  • Microsoft Money 2001 Deluxe Edition
  • MSN Money
  • MSN Money Plus
  • Microsoft Money Essentials

Important This article contains information that shows you how to help lower security settings or how to turn off security features on a computer. You can make these changes to work around a specific problem. Before you make these changes, we recommend that you evaluate the risks that are associated with implementing this workaround in your particular environment. If you implement this workaround, take any appropriate additional steps to help protect your system.
Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SUMMARY

This article describes how to troubleshoot a problem that occurs where you cannot update online quotes in Microsoft Money, MSN Money, or MSN Money Plus. This article lists the symptoms of this problem and provides troubleshooting steps to isolate the cause. It also provides steps to resolve the problem.

SYMPTOMS

When you try to update online quotes, you may experience one or more of the following symptoms:
  • The last updated date does not change in your Portfolio or in the Call Summary section.
  • Money stops responding (hangs) during the update process.
  • The process updates the date and the time in the Call Summary section, but prices are not updated as expected.
  • Specific investments are not updated.
Additionally, you may receive an error message that is similar to one of the following:
Money was unable to connect to the online quotes server. Check your Internet connection and try the operation again.
Your last call encountered an error date. Money was unable to connect to the online quotes server. Check your Internet connection and try the operation again. An Internet communication error occurred. Please try your call again later OFXIE12029
Your last call encountered an error:
Money was unable to complete the operation. There is a problem with your Money installation. Please reinstall Money from your original product disks.
No quotes available at this time
We're sorry, but investment quotes are not available at this time. Please try again soon.
News is not available at this time.

CAUSE

This problem may occur if one or more of the following conditions are true:
  • The quotes server is not providing updated quotes.
  • You do not have Internet connectivity.
  • The symbol for one or more of your securities has changed or is not recognized by the quotes data providers.
  • Firewall or other security software such as Microsoft antispyware that is installed on your computer is preventing the quotes from updating.
  • The system date in the computer is incorrect.
  • You have Money configured to update too many quotes over your Internet connection.
  • An MSN Money Deluxe ActiveX control Portfolio (Investment Toolbox) control is out-of-date or is corrupted.
  • A registry subkey does not contain a valid URL for the Money quotes server.
  • Your installation of Money is damaged.
  • The video driver that is installed on the computer is causing the computer to stop responding.

RESOLUTION

To see whether there are any known problems with the Quote servers, visit the following MSN Money Network Status page: To troubleshoot this problem, follow these steps.

Step 1: Test your Internet connection

To test your Internet connection, visit the following Microsoft Web sites:If you cannot connect to these Web sites, contact your Internet Service Provider (ISP) to troubleshoot your Internet connection.

Step 2: If you are using Microsoft Money, test your Internet connection in Money

  1. Log on to your Internet Service Provider.
  2. Start Money.
  3. Assign Microsoft Network Passport credentials (the e-mail address and password that you use to sign in to the Passport Network) to your Money data file. If you already have Passport Network credentials that are assigned to your file, sign in to the Passport Network on line. To assign Passport Network credentials to your Money data file, follow these steps:
    1. Click File, and then click Password Manager.
    2. Click Use Passport Sign-In.
    3. Type your Passport Network e-mail address and password. If you do not have an existing Passport Network e-mail address or password, visit the following Microsoft Web site to create Passport Network credentials before you follow this step:
    4. Click Sign In.
If this connection is successful, go to the "Step 3: Test your symbols" section.

If you receive an error message when you try to sign in to the Passport Network, see the following articles in the Microsoft Knowledge Base. For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:

891338 Error messages that you receive when you try to open Money by using your Passport Network credentials

891337 You receive the "A communication error occurred" error message when you start Money 2005

Step 3: Test your symbols

Note Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.
To test your stock symbols, follow these steps:
  1. Visit the following MSN Web site:
  2. In the Symbols box, type the symbol for the investments in Money, click Go, and then make a not of the data that is returned.
  3. Repeat step 2 later to verify that you receive updated quotes.
If you cannot receive updated quotes on this computer, repeat steps 1 through 3 on another computer. If you cannot update quotes on either computer, there may be a problem with the symbols that are used. If this is the case, go to the "Step 6: Verify stock symbols" section. If you can update quotes on the second computer but not on your primary computer, go to the "Step 4: Temporarily turn off or remove firewall, antivirus, or other security software" section.

Step 4: Temporarily turn off or remove firewall, antivirus, or other security software

Warning This workaround may make your computer or your network more vulnerable to attack by malicious users or by malicious software such as viruses. We do not recommend this workaround but are providing this information so that you can implement this workaround at your own discretion. Use this workaround at your own risk.
To test this problem, temporarily turn off or remove any third-party firewall programs, antivirus, or other security software that is installed on the computer. For more information about how to turn off or remove this software, contact the manufacturer of your software.

Note Disabling the software does not always completely disable it. If you disable the software and the problem is not resolved, try temporarily removing the software.

If this resolves the problem, you may be able to add *.moneycentral.msn.com to the software's exception or "trusted sites" list. Contact the manufacturer for more information about how to do this.

If you installed Microsoft Windows XP Service Pack 2 (SP2), you can turn off the firewall software that is installed by Windows XP SP2. To do this, follow these steps:
  1. Click Start, click Run, type Firewall.cpl, and then click OK.
  2. Click Off (not recommended), and then click OK.
  3. Try to update online quotes again.
Note Customized browser settings can also cause this problem. Restoring default settings or adding *.moneycentral.msn.com to Trusted Sites, or both, may resolve this problem. Contact support for your browser for more information.

Step 5: Determine the number of quotes that your Internet connection can update

There is no set limit for the number of online quote updates that you can request. However, you may find that a slower connection such as a dial-up connection has a reduced effective limit on the number of quotes compared to a faster connection such as a broadband connection. To determine the number of quotes your connection will support, follow these steps.

Microsoft Money 2005 and later versions of Money

  1. Open the Portfolio Manager. To do this, click Investing, click Investing Tools, and then click Portfolio Manager.
  2. Click Update prices, and then click Pick quotes to download.
  3. Click to clear the check boxes for all the investments except the following, and then try to update online quotes again:
    • Dow Jones Industrial Average
    • Nasdaq Composite Index
    • Standard & Poor's 500
  4. If you can update quotes as expected, reopen the Pick Quotes to Download box.
  5. Click to select between 5 and 10 additional symbols, and then try to update online quotes again.
  6. If you can update online quotes, repeat steps 4 and 5 to add more symbols until you cannot update online quotes.
  7. Reopen the Pick Quotes to Download box.
  8. Click to clear the check boxes for the investments until you can update online quotes.
After you identify the investments that you cannot download, visit the following Money Web site to verify the symbol for those investments and make sure that they are recognized:

Microsoft Money 2004 and earlier versions

  1. Click Investing, click Portfolio under Common Tasks, click Update prices, and then click Pick quotes to download.
  2. Click to clear the check boxes for all the investments except the following, and then try to update online quotes again:
    • Dow Jones Industrial Average
    • Nasdaq Composite Index
    • Standard & Poor's 500
  3. If you can update quotes as expected, click Portfolio Manager, click Update prices under Common Tasks, and then click Pick quotes to download.
  4. Click to select between 5 and 10 additional symbols, and then try to update online quotes again.
  5. If you can update online quotes, repeat steps 3 and 4 to add more symbols until you cannot update online quotes.
  6. Click Portfolio Manager, click Update prices under Common Tasks, and then click Pick quotes to download.
  7. Click to clear the check boxes for the investments until you can update online quotes.

Step 6: Verify stock symbols

If a stock symbol changes, the old symbol may continue to work for a short time. When the old symbol is no longer valid, Money cannot update the symbol. Additionally, the symbols that are recognized by the MSN Money quote servers and data providers may differ from the symbols that you are using. You can use Find Symbol in Money or on MSN Money to see whether there is a recognized symbol that you can use. To use Find Symbol on MSN Money, follow these steps:
  1. Visit the following Microsoft Web site:
  2. Click Investing, and then click Stocks.
  3. Click Find Symbol or Find.
  4. Look up part of the investment name.
To change the symbol of an investment, follow these steps:
  1. Go to the Portfolio Manager.
  2. Right-click the investment, and then locate Investment Details.
  3. Change the symbol.

Step 7: Install the latest version of MSN Money's Deluxe (ActiveX) Portfolio (Investment Toolbox) Controls

For more information about how to update the MSN Money ActiveX controls, click the following article number to view the article in the Microsoft Knowledge Base:

176841 How to remove and reinstall the MSN Money Investing components

Step 8: Verify the URL for the online quote server

Verify that the QuoteServerURL registry value is correct

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.
  1. Quit Money.
  2. Click Start, click Run, type regedit, and then click OK.
  3. Locate the following registry subkey:

    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Investor



    Note If this registry subkey does not exist, go to the "Step 9: Remove and then reinstall Money" section, and then reinstall Money.
  4. Locate the following registry subkey:

    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Investor\StockQuotes\QuoteServerURL

  5. In the right pane, right-click URL, click Modify, type the following text in the Value data box, and then click OK: http://data.moneycentral.msn.com/Scripts/invisapi.dll/
  6. Click File, and then click Exit.
  7. Start Money, and then try to update quotes again.

Step 9: Remove and then reinstall Money

For more information about how to remove and then reinstall Money, click the following article number to view the article in the Microsoft Knowledge Base:

895866 How to remove and reinstall Microsoft Money

Step 10: Test the online updates by using VGA Mode

Note Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.
When you update online quotes, a progress bar appears on the screen. If the video driver that is installed on your computer cannot display this feature correctly, your computer may stop responding (hang).

To enable VGA Mode on your computer, follow these steps:
  1. Click Start, click Run, type msconfig, and then click OK.
  2. On the BOOT.INI tab, click to select the /BASEVIDEO check box, and then click OK.
  3. Restart the computer, and then test online updates again.

Modification Type:MinorLast Reviewed:7/14/2006
Keywords:kbprb kbtshoot KB873204 kbAudEndUser