You receive the "Disk is full" error message and Word quits unexpectedly when you try to save a document in Word 2000 (873101)



The information in this article applies to:

  • Microsoft Word 2000


Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

If you try to save a document in Microsoft Word 2000 while you continue to work in the document, you may receive a "drive is full" error message. If you click OK in the "drive is full" error message and then try to continue working in the document, Word 2000 quits unexpectedly, and you receive the following error message:

Microsoft Word has encountered a problem and needs to close. We are sorry for the inconvenience.

If you view the details of the error message, you receive an error signature similar to the following:
Application Name  Application Version  Module Name  Module Version  Offset
---------------------------------------------------------------------------
Winword.exe       9.0.0.8119           Unknown      0.0.0.0         00000000

CAUSE

This issue may occur when the Allow background saves option is turned on in Word 2000.

The Allow background saves option lets you continue working on a document while Word 2000 saves the changes to the document in the background.

To turn on the Allow background saves option in Word 2000, follow these steps:
  1. Start Word 2000.
  2. On the Tools menu, click Options.
  3. On the Save tab, click to select the Allow background saves check box, and then click OK.

RESOLUTION

How to obtain the hotfix

This issue is fixed in the Word 2000 post-Service Pack 3 Hotfix Package that is dated June 29, 2004. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

870755 Description of the Word 2000 post-Service Pack 3 hotfix package: June 29, 2004

After you install this hotfix, follow the steps that are listed in the "More Information" section of this article to set the EnableQfe11876Fix registry key and to activate the hotfix.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To activate this hotfix, follow these steps:
  1. Quit Word 2000.
  2. Click Start, and then click Run.
  3. In the Open box, type regedit, and then click OK.
  4. Locate, and then click to select the following registry key:

    HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Word\Options

  5. After you select the key that is specified in step 4, point to New on the Edit menu, and then click DWORD Value.
  6. Type EnableQfe11876Fix, and then press ENTER.
  7. Right-click EnableQfe11876Fix, and then click Modify.
  8. In the Value data box, type 1, and then click OK.
  9. On the File menu, click Exit to quit Registry Editor.

Modification Type:MajorLast Reviewed:7/14/2004
Keywords:kberrmsg kbOffice2000sp4fix kbfix kbbug kbQFE KB873101 kbAudITPRO kbAudEndUser