The quorum log file becomes corrupted in your Windows 2000 Advanced Server-based cluster environment (872970)



The information in this article applies to:

  • Microsoft Windows 2000 Advanced Server

SYMPTOMS

In your Microsoft Windows 2000 Advanced Server-based cluster environment, the quorum log file (Quolog.log) of the cluster becomes corrupted. Therefore, the Cluster service may not start. You may receive the following error message when you try to start the Cluster service:
Could not start the Cluster Service on Local Computer. Error 1067: The process terminated unexpectedly.
Additionally, the following events may be logged in the system event log: Event ID: 1019
Type: Warning
Source: ClusSvc
Category: Log Mgr
Description:
The log file Q:\MSCS\quolog.log was found to be corrupt. An attempt will be made to reset it, or you should use the Cluster Administrator utility to adjust the maximum size. Event ID: 1148
Type: Error
Source: ClusSvc
Category: Log Mgr
Description:
Cluster service encountered a fatal error. The vital quorum log file 'Q:\MSCS\quolog.log' is corrupt. If you have a backup of the quorum log file, you may try to start Cluster service by entering 'clussvc -debug -noquorumlogging' at a command window, copy the backed up quorum log file to the MSCS directory on the quorum drive, stop Cluster service, and restart Cluster service normally using the 'net start clussvc' command. If you do not have a backup of the quorum log file, you may try to start Cluster service as 'clussvc -debug -resetquorumlog' and this will attempt to create a new quorum log file based on possibly stale information in the server cluster database. You may then stop Cluster service and restart it normally using the 'net start clussvc' command.

CAUSE

This problem may occur when one of the following conditions is true:
  • The reserve handlers, the disk arbitration handlers, or the write failure handlers for the Clusdisk.sys driver set a disk state to offline. If these handlers do not take the disk offline correctly, the quorum log file may be corrupted.
  • The Cluster service (Clussvc.exe) moves the checkpoint file from the quorum disk to its local cluster database file. Because the file move deletes the original copy of the checkpoint file, the quorum disk may be left without a checkpoint file if the Cluster service stops before a new checkpoint is taken. This condition may cause the quorum log file to be corrupted.
  • The quorum log mount code has a time stamp check code. The time stamp check code may delete data from the quorum log if the time is not synchronized on the cluster nodes. This condition may lead to a missing checkpoint file. A missing checkpoint file may cause the quorum log file to be corrupted.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

The following must be installed on your computer before you apply this hotfix:
  • Microsoft Windows 2000 Service Pack 3 or later versions
  • The Cluster service

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version         Size       File name
   ----------------------------------------------------------
   19-Jun-2003  20:05  5.0.2195.6683      55,568  Clusapi.dll
   13-Jul-2004  21:02  5.0.2195.6960      75,568  Clusdisk.sys
   19-Jun-2003  20:05  5.0.2195.6683      67,760  Clusnet.sys
   13-Jul-2004  21:02  5.0.2195.6960     691,472  Clussvc.exe
   19-Jun-2003  20:05  5.0.2195.6660      95,504  Netman.dll
   19-Jun-2003  20:05  5.0.2195.6604     477,456  Netshell.dll
   19-Jun-2003  20:05  5.0.2195.6683      54,544  Resrcmon.exe
   04-Jun-2004  23:13  5.0.2195.6935   5,887,488  Sp3res.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

This hotfix is included in the list of recommended hotfixes to be proactively applied to Windows 2000 server clusters. Click the following article number to view the article that contains this list in the Microsoft Knowledge Base:

895090 Recommended hotfixes for Windows 2000 Service Pack 4-based server clusters

This hotfix should be evaluated and applied proactively to all server clusters that are prone to be negatively affected by the problem that is described in this article.

You can apply this hotfix to prevent quorum log file corruption. The hotfix does not fix a quorum log file that is already corrupted. To recover from a quorum log file that is corrupted, you must either rebuild or restore the quorum log file. For additional information about how to recover from a corrupted quorum log file, click the following article numbers to view the articles in the Microsoft Knowledge Base:

245762 Recovering from a lost or corrupted quorum log

257905 Error message: Could not start the Cluster service on the local computer

For additional information about how hotfix packages are named, click the following article numbers to view the articles in the Microsoft Knowledge Base:

816915 New file naming schema for Microsoft Windows software update packages

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbBug kbfix kbWin2000preSP5fix kbHotfixServer kbQFE KB872970 kbAudITPRO