FIX: Interix processes do not detect a modem's Carrier Detect signal in Windows Services for UNIX 3.5 (872961)



The information in this article applies to:

  • Microsoft Windows Services for UNIX 3.5

SYMPTOMS

Interix processes do not detect a modem's Carrier Detect (CD) signal in Microsoft Windows Services for UNIX 3.5.

CAUSE

The COM port is not released after an Interix process that uses the port exits. This problem prevents other processes from using the COM port. Processes that are prevented from using the port include non-Interix processes.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart Requirement

You must restart the computer because the POSIX subsystem is replaced when you install the hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   14-Jul-2004  01:59  8.0.1969.12       131,072  Posix.exe        
   14-Jul-2004  01:59  8.0.1969.12       104,448  Psxrun.exe       
   14-Jul-2004  01:59  8.0.1969.12       763,904  Psxss.exe

WORKAROUND

To work around this problem, configure the modem to make sure that the CD signal is always transmitted.

Note This workaround may have unexpected results in some applications because the CD signal is sent before the remote terminal is actually connected.

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Interix does not start receiving data from a modem until the CD pin is signaled. The CD pin is also known as the Receive Line Signal Detect (RLSD). Generally, modems set this pin after they negotiate a connection with the remote modem. However, direct computer-to-computer connections are ordinarily configured so that the CD is always signaled.

The modem's settings may affect whether this problem occurs. Also, the problem appears to be more likely to occur with some serial drivers. For example, the problem is more likely to occur on Microsoft Windows Server 2003 than on Windows 2000 Server.

This issue does not apply to direct computer-to-computer connections.

For more information about Windows Services for UNIX, visit the following Microsoft Web site:

Modification Type:MinorLast Reviewed:6/2/2006
Keywords:kbBug kbfix kbQFE kbHotfixServer KB872961 kbAudDeveloper