The HOMEPATH environment variable is not correct after you use a Telnet session to connect to a Windows Server 2003-based computer (872824)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

When you use a Telnet session to connect to a Microsoft Windows Server 2003-based computer, the HOMEPATH environment variable for your user account may not be correct after you log on to the Windows Server 2003-based computer.

CAUSE

This problem occurs when the following conditions are true:
  • The Telnet client is authenticated by using password authentication.
  • The Telnet client has a home folder that is located on a remote computer.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Microsoft Windows Server 2003, 32-bit editions

Date         Time   Version            Size    File name
--------------------------------------------------------------
20-Jul-2004  01:39  5.2.3790.194       77,824  Tlntsess.exe

Microsoft Windows Server 2003, 64-Bit Enterprise Edition

Date         Time   Version            Size    File name       Platform
-----------------------------------------------------------------------
20-Jul-2004  01:41  5.2.3790.194      196,608  Tlntsess.exe    IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

To determine the authentication method that the Telnet service on the Windows Server 2003-based computer is using, run the Tlntadmn.exe tool. To do this, follow these steps:
  1. Click Start, click Run, type cmd, and then click OK.
  2. At the command prompt, type tlntadmn, and then press ENTER.
For a list of Tlntadmn.exe options, type the following:

tlntadmn -?

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbBug kbfix kbWinServ2003preSP1fix KB872824 kbAudITPRO kbAudEndUser