Software inventory data is not migrated when you upgrade to Systems Management Server 2003 (872815)



The information in this article applies to:

  • Microsoft Systems Management Server 2003

SYMPTOMS

After you upgrade from Microsoft Systems Management Server (SMS) 2.0 to SMS 2003, software inventory data might not have migrated from the SMS 2.0 database.

CAUSE

This problem occurs if a gap of more than 1,000 client IDs exists in the list of client IDs in the SoftwareInventory table. For example, the SoftwareInventory table may contain the following client IDs:

10 - 800
145 - 1,220
650 - 650
992 - 1,900
2200 - 655
2900 - 822

In this example, six clients exist in the SoftwareInventory table before you upgrade to SMS 2003. After you upgrade to SMS 2003, the first four client's software inventory appears in the database. However, the remaining two clients are not in the database because the client IDs increase from 992 to 2,200. Additionally, this increase if more than 1,000 client IDs.

Large gaps in client IDs can occur in large environments where clients are regularly deleted from the database. User account or group discovery can also cause gaps in the client IDs. Both discovery methods use the same group of available IDs that are used to identify system resources.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Systems Management Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version       Size       File name
   ------------------------------------------------------
   25-Dec-2003  10:00  2.50.2726.20  3,227,648  Setup.exe
Note Because of file dependencies, the most recent hotfix that contains this file may also contain additional files.

This hotfix provides a replacement for the Setup.exe file on the SMS 2003 installation CD-ROM. To use this hotfix, you must copy the contents of the SMS 2003 installation CD-ROM to a folder on your hard disk, and then replace the existing Setup.exe file with the hotfix version of the Setup.exe file. To do this, follow these steps to create a local installation point for SMS 2003:
  1. Create a folder with a descriptive name on a disk drive with at least 275 megabytes of available drive space. For example, you could create a folder that is named SMS2003.CD.
  2. Use Windows Explorer to copy the contents of the SMS 2003 installation CD to the folder that you created in step 1.
  3. Rename the existing Setup.exe file in the SMSSETUP\Bin\I386 folder to Setup_rtm.exe.
  4. Run the Sms2003-rtm-kb872815-x86-enu.exe hotfix file to extract the hotfix files.
  5. Copy the hotfix Setup.exe file to the SMSSETUP\Bin\I386 folder on the hard disk drive.
  6. If you want to upgrade multiple sites to SMS 2003, share the folder on the network so that the folder can be used as a common installation point for SMS 2003.
  7. To install a new SMS 2003 site or upgrade an SMS 2.0 site, run the hotfix Setup.exe file from the SMSSETUP\Bin\I386 folder.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

To determine if you might experience this problem before you upgrade to SMS 2003, follow these steps:
  1. Click Start, point to Programs, point to Microsoft SQL Server, and then click Query Analyzer.
  2. Connect to the computer that is running SQL Server.
  3. On the Query menu, click Change Database.
  4. Click the database for your SMS 2.0 site, and then click OK.
  5. In the Query box, type select clientid, count(*) from SoftwareInventory group by clientid order by 1.
  6. On the Query menu, click Execute.
In the query results list, look for two client IDs with a gap of 1,000 or more. In the previous example, 992 and 2,200 have a gap of over 1,000. The software inventory data for all clients that are listed after the gap will not be migrated when you upgrade to SMS 2003.

Note Software inventory data that was not migrated is recovered when the clients process resync requests after an upgrade. For more information about inventory resynchronization, see Chapter 3, "Hardware and Software Inventory", in the Systems Management Server 2003 Concepts, Planning, and Deployment Guide.

For additional information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MajorLast Reviewed:4/7/2006
Keywords:kbQFE KBHotfixServer kbDatabase kbClient kbSMSTopazFix kbUpgrade kbsetup kbInventory kbfix kbBug KB872815 kbAudITPRO