You may not receive an error message when the Csvde.exe utility does not successfully export Active Directory data in Windows 2000 (872799)



The information in this article applies to:

  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional

SYMPTOMS

When you try to use the Csvde.exe utility to export Active Directory data in a Microsoft Windows 2000-based environment, and the export operation does not succeed, you may not receive an error message. Additionally, the value of the ERRORLEVEL environment variable may be 0, indicating that the export operation completed successfully.

CAUSE

This problem occurs because the Csvde.exe utility does not exit with the correct error value when the Ldap_get_next_page_s function returns an error.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have Windows 2000 with Service Pack 3 or Service Pack 4 installed on your computer to install this hotfix.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version         Size    File name
   -----------------------------------------------------
   13-Aug-2004  17:07  5.00.2195.6968  40,720  Csvde.exe

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

The ERRORLEVEL environment variable gives information about a recently used program or command. Typically, a nonzero value indicates an error. To check the value of the ERRORLEVEL environment variable, type echo %ERRORLEVEL% at a command prompt.

For additional information about the Csvde.exe utility, click the following article number to view the article in the Microsoft Knowledge Base:

276440 How to use Csvde.exe to back up and restore connection agreements

For additional information about the new file naming schema for Microsoft Windows software update packages, click the following article number to view the article in the Microsoft Knowledge Base:

816915 New file naming schema for Microsoft Windows software update packages

For additional information about the terminology that is used in this article, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbBug kbfix kbWin2000preSP5fix kbHotfixServer kbQFE KB872799 kbAudITPRO