IIS stops responding, and you cannot connect to a particular Web site when you use WinHTTP in Windows 2000 Server with Service Pack 4 (872766)



The information in this article applies to:

  • Microsoft Windows HTTP Services (WinHTTP) 5.1, when used with:
    • Microsoft Windows 2000 Server SP4

SYMPTOMS

Assume the following scenario: You use Microsoft Windows HTTP Services (WinHTTP) to connect to a particular Web site on a Microsoft Windows 2000 Server-based computer with Service Pack 4 (SP4) applied. Additionally, this computer is running Microsoft Internet Information Services (IIS). In this scenario, you may experience the following symptoms:
  • IIS stops responding (hangs).
  • You cannot connect to the Web site in question.

CAUSE

This problem occurs because of a global critical section leak by WinHTTP. This leak causes all calls that require the critical section to wait until IIS processes are restarted.

Note IIS processes are never automatically restarted in this scenario, and therefore the calls are never completed.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   ----------------------------------------------------------
   11-Jun-2004  01:04  5.1.2600.1557     331,776  Winhttp.dll  

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:

816915 New file naming schema for Microsoft Windows software update packages

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbBug kbfix kbHotfixServer kbQFE KB872766 kbAudITPRO