You are prompted to install drivers for an upgraded device when you upgrade the firmware on a SCSI device in Windows Server 2003 (871268)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

When you upgrade the firmware on a small computer system interface (SCSI) device and then restart Microsoft Windows Server 2003, the Add New Hardware Wizard unexpectedly starts. Then, the wizard prompts you for the location of drivers to install for the upgraded device.

Note Examples of a SCSI device include a hard disk, a redundant array of independent disks (RAID) controller, and a tape drive.

CAUSE

This issue occurs because the SCSI device is detected as a new device after the firmware upgrade.

The Microsoft Windows Plug and Play manager obtains the firmware revision number from a SCSI device. This revision number then becomes part of the device's Plug and Play ID string. When the upgraded device is enumerated, the new firmware revision number generates a new unique Plug and Play ID for the device. Therefore, the device is recognized as a new device instead of as the same device that has already been enumerated.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel. Windows Server 2003 32-bit editions
   Date         Time   Version            Size    File name
   -----------------------------------------------------------
   21-Jul-2004  16:01  5.2.3790.195      127,488  Scsiport.sys 
Windows Server 2003 64-bit editions
   Date         Time   Version            Size    File name
   -----------------------------------------------------------
   21-Jul-2004  03:02  5.2.3790.195      292,352  Scsiport.sys

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/2/2006
Keywords:kbBug kbfix kbWinServ2003preSP1fix kbQFE kbHotfixServer KB871268 kbAudITPRO kbAudOEM