You receive an "HTTP 500 Internal Server Error" error message when you try to access an Exchange mailbox by using Outlook Web Access (871013)



The information in this article applies to:

  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you try to access an Exchange mailbox by using Microsoft Office Outlook Web Access for Exchange Server 2003, you receive the following error message:
HTTP 500 Internal Server Error

CAUSE

This issue may occur when the mailbox that you are trying to access is hosted on a clustered Microsoft Exchange 2000 Server back-end server and you are using a Web browser to gain access to Outlook Web Access on an Exchange 2003 front-end server.

In Exchange 2003 Outlook Web Access, the front-end server checks the networkaddress attribute value when it tries to connect to an Exchange back-end server. (Exchange 2000 Outlook Web Access does not do this.) The front-end server requires a fully qualified domain name (FQDN) value, and it checks for a period in the value that is returned for the networkaddress ncacn_ip_tcp registry entry. If this value is just a host name or a network basic input/output system (NetBIOS) name and not an FQDN, the connection request for the mailbox on the specific back-end server fails and the front-end server returns an "HTTP 500 Internal Server Error" error message to the user.

RESOLUTION

To resolve this problem, follow these steps on your Exchange 2000 or Exchange 2003 back-end server. Alternatively, follow these steps on another computer that has access to the same domain controller and the same global catalog server.

Note This procedure requires the ADSI Edit tool (AdsiEdit.msc). The ADSI Edit tool is included in Microsoft Windows 2000 Support Tools or Microsoft Windows Server 2003 Support Tools. For additional information about the ADSI Edit tool and the Windows Support Tools, see the "More information" section. To force Exchange 2003 Outlook Web Access to use an FQDN value in the scenario described in this article, follow these steps.

Warning If you use the ADSI Edit snap-in, the LDP utility, or any other LDAP version 3 client, and you incorrectly modify the attributes of Active Directory objects, you can cause serious problems. These problems may require you to reinstall Microsoft Windows 2000 Server, Microsoft Windows Server 2003, Microsoft Exchange 2000 Server, Microsoft Exchange Server 2003, or both Windows and Exchange. Microsoft cannot guarantee that problems that occur if you incorrectly modify Active Directory object attributes can be solved. Modify these attributes at your own risk.
  1. Start the ADSI Edit tool from Windows 2000 Support Tools or from Windows Server 2003 Support Tools.
  2. Expand the following nodes:
    • Configuration Container
    • Configuration
    • Services
    • Microsoft Exchange
    • Organization_Name
    • Administrative Groups
    • Your_First_Administrative_Group
    • Servers
  3. Right-click Your_back-end_Exchange_server, and then click Properties.
  4. Click networkaddress in the Attributes list, and then click Edit.
  5. Add a new value for ncacn_ip_tcp. Use the FQDN of the server instead of the NetBIOS name or the host name of the server.

    The syntax for this value is ncacn_ip_tcp:FQDN. For example, if your Exchange back-end server has a host name of EXCHANGE1 and the FQDN is EXCHANGE1.domain.com, use the following value for ncacn_ip_tcp: ncacn_ip_tcp:EXCHANGE1.domain.com
  6. Remove the old ncacn_ip_tcp value that contains the NetBIOS name or the host name of the back-end server.
  7. Apply this change.
  8. Because your Exchange computer may change this value back during a failover or a system attendant restart, configure the following registry value on both nodes of the cluster:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\UpdateProtocols

    Note If the UpdateProtocols value is not present, create it. To do this, follow these steps.

    Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
    1. Start Registry Editor.
    2. Locate the following registry subkey:

      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeSA\Parameters\

    3. Right-click Parameters, point to New, and then click DWORD Value.
    4. Type UpdateProtocols, and then press ENTER.
  9. Right-click UpdateProtocols, click Modify, type 0 in the Value data box, and then click OK.
  10. If your network uses a Hosts file on the back-end cluster node, modify it by using the following order of entry:
    IPAddress to FQDN
    IPAddress to NetBIOS
    instead of:
     
    IPAddress to NetBIOS
    IPAddress to FQDN
  11. Restart the Exchange services on the back-end cluster node.
  12. If there are multiple domain controllers, wait for replication to occur before you try to log on from the front-end server. If the problem is not resolved after replication is complete, restart the IIS Admin Service on the front-end server.

MORE INFORMATION

Install the ADSI Edit tool from the Support\Tools folder on your Windows 2000 or Windows Server 2003 installation CD. You can also obtain the ADSI Edit tool by visiting the following Microsoft Web site:

Note The hotfix that is described in the following article discusses an issue that is similar to the one that is discussed in this article:

329938 Cannot use Outlook Web Access to access an Exchange server installed on a Windows 2000 cluster node

If you continue to experience the symptoms that are described in this article, you may have to install this hotfix.

For additional information about troubleshooting "HTTP 500 Internal Server Error" error messages with Outlook Web Access, click the following article numbers to view the articles in the Microsoft Knowledge Base:

833001 Users cannot access Outlook Web Access after you apply security templates from the Security Operations Guide for Windows 2000

316349 "HTTP 500 - Internal Server Error" error message occurs when you use Outlook Web Access to access a front-end server

301428 Troubleshooting Outlook Web Access from an IIS perspective


Modification Type:MinorLast Reviewed:11/10/2005
Keywords:kbtshoot kbprb KB871013 kbAudITPRO