Printer tray assignments on a print server may not transfer to the client computer when you install a network printer in Windows XP or Windows Server 2003 (870981)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional

For a Microsoft Windows 2000 version of this article, see 870980.

SYMPTOMS

If you install a network printer on a Microsoft Windows XP-based or Microsoft Windows Server 2003-based client computer from a Windows XP-based or Windows Server 2003-based print server, the tray assignments on the printer may not transfer to the client computer. When you view the tray assignments on the client computer, the tray appears as not available.

CAUSE

This problem may occur if the client computer uses a language version of Windows XP or Windows Server 2003 that is different from the version that is used by the print server.

RESOLUTION

To resolve this problem, install this hotfix on both the print server and the client computer.

Windows Server 2003

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.PrerequisitesNo prerequisites are required.Restart requirementYou do not have to restart your computer after you apply this hotfix. However, when you install this hotfix, the server may spend up to two hours regenerating the parsed binary printer description files (.bud files) that are used to increase spooler efficiency for the drivers. During this time, Print Spooler cannot receive incoming print jobs and may return messages to clients that indicate that the print queue is full. This is a one-time parsing operation and does not occur after the parsed binary .bud files are successfully regenerated. Therefore, we recommend that you schedule this hotfix installation to allow for this delay. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

832219 Users cannot print after you install a service pack, update rollup, or printer hotfix on a server in Windows 2000

Hotfix replacement informationThis hotfix does not replace any other hotfixes.File information The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003, 32-bit x86-based versions
   Date         Time   Version       Size     File name
   -------------------------------------------------------
   10-Nov-2004  18:42  0.3.3790.231  133,120  Ps5ui.dll
   10-Nov-2004  18:42  0.3.3790.231  464,896  Pscript5.dll
   10-Nov-2004  18:42  0.3.3790.231  265,216  Unidrv.dll
   10-Nov-2004  18:42  0.3.3790.231  203,264  Unidrvui.dll


Windows Server 2003, 64-bit Itanium-based versions
   Date         Time   Version       Size       File name     Platform
   -------------------------------------------------------------------
   10-Nov-2004  18:36  0.3.3790.231    366,080  Ps5ui.dll     IA-64
   10-Nov-2004  18:36  0.3.3790.231  1,003,520  Pscript5.dll  IA-64
   10-Nov-2004  18:36  0.3.3790.231    797,184  Unidrv.dll    IA-64
   10-Nov-2004  18:36  0.3.3790.231    523,776  Unidrvui.dll  IA-64

Windows XP

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.File information The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version          Size  File name
   -------------------------------------------------------
   17-Mar-2005  18:54  0.3.3790.288  133,120  Ps5ui.dll
   17-Mar-2005  18:54  0.3.3790.231  464,896  Pscript5.dll
   17-Mar-2005  18:54  0.3.3790.231  248,832  Unidrv.dll
   17-Mar-2005  18:54  0.3.3790.231  198,144  Unidrvui.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:

816915 New file naming schema for Microsoft Windows software update packages

For more information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/2/2006
Keywords:kbWinXPsp3fix kbWinXPpreSP3fix kbBug kbfix kbWinServ2003preSP1fix kbQFE kbHotfixServer KB870981 kbAudEndUser