You cannot back up the %windir%\SoftwareDistribution folder by using the NovaStor NovaNet-WEB backup program on Windows XP Service Pack 2 (870902)



The information in this article applies to:

  • Microsoft Windows XP Professional Service Pack 2 (SP2)
  • Microsoft Windows XP Home Edition Service Pack 2 (SP2)

SYMPTOMS

When you try to back up your Microsoft Windows XP Service Pack 2 (SP2)-based computer by using the third-party NovaStor Corporation NovaNet-WEB backup program, the NovaNet-WEB program may not back up files that are located in the %windir%\SoftwareDistribution folder. You may receive a log entry that is similar to the following log entry in the backup log:
***The process cannot access the file because it is being used by another process.
	File:  c:\WINDOWS\SoftwareDistribution\DataStore\DataStore.edb
***The process cannot access the file because it is being used by another process.
	File:  c:\WINDOWS\SoftwareDistribution\DataStore\Logs\edb.log
***The process cannot access the file because it is being used by another process.
	File:  c:\WINDOWS\SoftwareDistribution\DataStore\Logs\tmp.edb
***The process cannot access the file because it is being used by another process.
	File:  c:\WINDOWS\SoftwareDistribution\EventCache\{C3DF80E7-C68C-4650-B73C-C577E29AsA3F}.bin
***The process cannot access the file because it is being used by another process.
	File:  c:\WINDOWS\SoftwareDistribution\EventCache\{D01A629B-E43D-419A-A6D5-6FBF07072491}.bin

CAUSE

This problem occurs because Windows XP exclusively opens the Extensible Storage Engine (ESE) database that the Microsoft Software Update Services (SUS) 2.0 version of the Automatic Updates service uses. Therefore, the third-party backup program cannot read the %windir%\SoftwareDistribution folder to build a backup image.

Note The %windir%\SoftwareDistribution folder was added in Windows XP SP2.

RESOLUTION

To resolve this problem, NovaStor Corporation recommends that you obtain and install the NovaStor Open File Manager for Windows module.

MORE INFORMATION

For more information about how to contact NovaStor Corporation, visit the following NovaStor Corporation Web site: The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.
Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

Modification Type:MinorLast Reviewed:8/26/2004
Keywords:kbAppCompatibility kb3rdparty kbBackup kbtshoot kbprb KB870902 kbAudITPRO kbAudEndUser