You receive a "Delayed Write Failed" error message in Windows XP Service Pack 2 or Windows XP Tablet PC Edition 2005 (870894)



The information in this article applies to:

  • Microsoft Windows XP Home Edition Service Pack 2 (SP2)
  • Microsoft Windows XP Media Center Edition Service Pack 2 (SP2)
  • Microsoft Windows XP Professional Service Pack 2 (SP2)
  • Microsoft Windows XP Tablet PC Edition 2005

SYMPTOMS

After you install Microsoft Windows XP Service Pack 2 (SP2) or Microsoft Windows XP Tablet PC Edition 2005, you may receive the following error message during ordinary usage:
Delayed Write Failed
Windows was unable to save all the data for the file drive_letter:\file_path\file_name. The data has been lost. This error may be caused by a failure of your computer hardware or network connection. Please try to save this file elsewhere.

CAUSE

This problem may occur if your computer uses a 3ware RAID controller, and you have configured the RAID controller for optimal performance. As part of your configuration, you turned off the following settings by modifying the CacheControl registry entry to the value of 0x00000031:
  • The FUA (Force Unit Access: write through) bit on SCSI writes
  • SRB flush commands
  • SCSI flush commands

WORKAROUND

To work around this problem you must set CacheControl to zero:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following key in the registry:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\3ware Storage Controller\Cache Control

  3. On the Edit menu, click Modify.
  4. Type 0, and then press ENTER.
  5. Quit Registry Editor.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about how to optimize your 3ware software, visit the following 3ware Web site: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information. The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:11/12/2004
Keywords:kbUpgrade kbsetup kbHardware kbDriver kbtshoot kberrmsg kbnofix kbBug KB870894 kbAudEndUser