BUG: You cannot reinstall Fujitsu NetCOBOL for .NET on a computer that has Visual Studio .NET 2003 installed (870807)



The information in this article applies to:

  • Microsoft Visual Studio .NET (2003), Professional Edition
  • Microsoft Visual Studio .NET (2003), Enterprise Architect Edition
  • Microsoft Visual Studio .NET (2003), Enterprise Developer Edition
  • Microsoft Visual Studio .NET (2003), Academic Edition

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

You cannot reinstall Fujitsu NetCOBOL for .NET on a computer that has Microsoft Visual Studio .NET 2003 installed.

CAUSE

When you install Fujitsu NetCOBOL for .NET, a registry key is created. This registry key must be removed automatically from the registry when you remove Fujitsu NetCOBOL for .NET. However, the registry key is not removed.

WORKAROUND

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.
  1. Click Start, click Run, type regedit, and then click OK.
  2. In Registry Editor, locate and then click the following registry key:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\VisualStudio\7.1\Setup\Visual Studio .NET Integrated Development Environment 2003 - English

    Note This article applies to all versions of Visual Studio .NET 2003. However this registry key is different for each edition of the product.
  3. In the right pane of Registry Editor, right-click the InstallSuccess registry key, and then click Delete. The Confirm Value Delete dialog box appears.
  4. Click Yes.
  5. Reinstall Fujitsu NetCOBOL for .NET.

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section.

REFERENCES

For more information, visit the following Microsoft Developer Network (MSDN) Web site: The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:2/10/2006
Keywords:kbvs2005swept kbvs2005doesnotapply kbtshoot kbRegistry kbbug KB870807 kbAudDeveloper