Your Windows Server 2003-based multiprocessor computer with an AMD chipset may occasionally stop responding (870679)



The information in this article applies to:

  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition

SYMPTOMS

Your Microsoft Windows Server 2003-based multiprocessor computer with an AMD chipset may occasionally stop responding (hang).

CAUSE

This problem may occur if your multiprocessor computer has an AMD-8131 HyperTransport PCI-X Tunnel Data chipset installed.

Specifically, this problem occurs when multiple nonmaskable interrupts (NMIs) occur at the same time. An NMI is an interrupt that cannot be overruled by another service request. A hardware interrupt is defined as nonmaskable if it bypasses and takes priority over interrupt requests that are generated by software, by the keyboard, or by other installed devices.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   05-Aug-2004  00:37  5.2.3790.197      103,936  Hal.dll          
   05-Aug-2004  00:37  5.2.3790.197      109,056  Halaacpi.dll     
   05-Aug-2004  00:37  5.2.3790.197       78,336  Halacpi.dll      
   05-Aug-2004  00:37  5.2.3790.197      116,736  Halapic.dll      
   05-Aug-2004  00:37  5.2.3790.197      111,104  Halmacpi.dll     
   05-Aug-2004  00:37  5.2.3790.197      117,760  Halmps.dll       
   05-Aug-2004  01:15  5.2.3790.197    2,407,424  Ntkrnlmp.exe
   05-Aug-2004  00:37  5.2.3790.197    2,064,896  Ntkrnlpa.exe     
   05-Aug-2004  00:37  5.2.3790.197    2,109,440  Ntkrpamp.exe
   05-Aug-2004  01:20  5.2.3790.197    2,207,744  Ntoskrnl.exe   
To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

889100 How to obtain the latest service pack for Windows Server 2003

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 1.

MORE INFORMATION

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.
For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbBug kbfix kbWinServ2003preSP1fix kbHotfixServer kbQFE KB870679 kbAudITPRO