Error "Setup was unable to install Microsoft CRM Server." occurs after you enter a license key during the upgrade of Microsoft CRM (870105)
The information in this article applies to:
- Microsoft Business Solutions CRM 1.0
- Microsoft CRM 1.2
TechKnowledge Content
SYMPTOMS
When Microsoft SQL Server and Microsoft CRM Server are installed on separate servers and you enter a license key during the 1.0 to 1.2 upgrade of Microsoft CRM, you may receive the following error:
Setup was unable to install Microsoft CRM Server. Setup was unable to grant access to the Microsoft CRM databases. Unknown error. (80040E14).
CAUSE
The upgrade script is attempting to grant a Microsoft SQL Server login called MYDOMAIN\MYCRMSERVER$ access to the MSCRM database. The upgrade fails because the MYDOMAIN\MYCRMSERVER$ login already existed and already was granted access and a role in the database.
RESOLUTION
Remove the MYDOMAIN\MYCRMSERVER$ SQL Server login from the Microsoft SQL Server using Microsoft SQL Enterprise Manager. To do so complete the following steps:
1. Click
Start, point to
Programs, point to
Microsoft SQL Server, and then click
Enterprise Manager.
2. Expand Microsoft SQL Servers, expand SQL Server Group, and then expand your SQL Server.
3. Expand
Security and then click
Logins.
4.
Right-click
MYDOMAIN\MYCRMSERVER$ and then click
Delete from the context menu.
5. Once this role is deleted, you can re-start the upgrade.
Note MYDOMAIN and MYCRMSERVER$ are used as an example in this article. You will see a login with the name of your domain, followed by the name of your Microsoft CRM Server, followed by a dollar sign ($).
This article was TechKnowledge Document ID: 34304
Modification Type: | Minor | Last Reviewed: | 4/4/2006 |
---|
Keywords: | kbMBSupgrade kbMBSMigrate KB870105 kbAudEndUser |
---|
|