Cannot access an InfoPath form from a computer that is in a domain that is not trusted in InfoPath 2003 (867433)



The information in this article applies to:

  • Microsoft Office InfoPath 2003, Service Pack 1 (SP1)

SYMPTOMS

You may create a Microsoft Office InfoPath 2003 Service Pack 1 form template that uses a Web service as either a primary data source or as a secondary data source. After you publish the form template by using Publishing Wizard in InfoPath 2003, you may receive the following message:

Your form template was successfully published to the following location:

publish location\infopathform.xsn

Users who have access to this location can now open new forms based on this form template and fill them out.

However, when you later access this form, you may receive one or both of the following messages:
  • You may receive the following error message:
    InfoPath cannot create a new, blank form.
    InfoPath cannot open the form. To fix this problem, contact your system administrator.
  • You may receive the following message:

    Enter your credentials to connect to the following Web service:
    http://servername/applicationname/webservice.asmx?wsdl
    User Name:
    Password:

    If you enter your credentials and then click OK, you are again prompted to enter your credentials.

CAUSE

This problem may occur if your computer is not trusted in the domain where the Web service is configured. This problem may also occur if you remove your computer from the domain after you publish the InfoPath 2003 form.

InfoPath 2003 does not currently support connections from a domain that is not trusted.

WORKAROUND

To work around this problem, access the InfoPath 2003 form from a computer that is trusted by the domain where the Web service is configured.

Modification Type:MajorLast Reviewed:8/5/2004
Keywords:kbtshoot kbnofix kbprb KB867433 kbAudDeveloper