You may receive an "Error encountered by Crystal PageServer. Error in formula. '({account.CFSXXXX} like '*XXXXX*')' This field name is not known," error message when you add a field to a form and you try to filter by the custom field in Microsoft CRM (859649)
The information in this article applies to:
- Microsoft CRM 1.2
- Microsoft Business Solutions CRM 1.0
TechKnowledge Content
SYMPTOMS
"Error encountered by Crystal PageServer. Error in formula. '({account.CFSXXXX} like '*XXXXX*')' This field name is not known. File a882db41facd610.rpt. [On Cache/Page Server: YYYYY.pageserver]" occurs after you add a new field to a form in Microsoft Business Solutions CRM and then you try to filter by the custom field.
CAUSE
You can filter Microsoft CRM Reports by using only the fields that are originally included with Microsoft CRM.
RESOLUTION To be able to filter Microsoft CRM Reports by using custom fields, you must purchase a full version of Crystal Reports Designer. Crystal Reports Designer lets you make the custom field available to the report. After the field has been made available to the report, you will be able to filter by the field. The field can be removed if you do not want it to be visible on the report.
ADDITIONAL INFORMATION
Microsoft CRM 1.0 requires Crystal Reports Designer 8.5, and Microsoft CRM 1.2 requires Crystal Reports Designer 9.0.
Crystal Reports Designer cannot be installed on the Microsoft CRM server, as it will conflict with the Crystal Enterprise installation that is automatically installed on the Microsoft CRM server. Installing Crystal Reports Designer on the CRM server is unsupported and may break reporting functionality.REFERENCESThis article was TechKnowledge Document ID: 30565
| Modification Type: | Minor | Last Reviewed: | 8/5/2005 |
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| Keywords: | kbMbsreports kbMBSMigrate KB859649 kbAudEndUser |
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