The screen saver does not start in a Windows 2000 Terminal Services console session (843564)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server

SYMPTOMS

When you configure Microsoft Windows 2000 Terminal Services console sessions to use a screen saver, the screen saver does not always start in the Terminal Services console sessions.

CAUSE

This problem may occur when a previous Terminal Services console session reached the session limit and then automatically ended the session while the screen saver was running.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Date         Time   Version            Size    File name
--------------------------------------------------------------
24-Mar-2004  02:17  5.0.2195.6824      42,256  Basesrv.dll      
21-Sep-2003  00:45  5.0.2195.6824     236,304  Cmd.exe          
19-Jun-2003  20:05  5.0.2195.6660     233,744  Gdi32.dll        
24-Mar-2004  02:17  5.0.2195.6897     742,160  Kernel32.dll     
24-Mar-2004  02:17  5.0.2195.6824      54,544  Mpr.dll          
14-Jul-2004  21:25  5.0.2195.6958     335,120  Msgina.dll       
24-Mar-2004  02:17  5.0.2195.6892      90,264  Rdpwd.sys
04-Jun-2004  23:13  5.0.2195.6935   5,887,488  Sp3res.dll       
24-Mar-2004  02:17  5.0.2195.6897     403,216  User32.dll       
05-Aug-2003  22:14  5.0.2195.6794     385,808  Userenv.dll      
14-Jul-2004  01:52  5.0.2195.6960   1,631,696  Win32k.sys
14-Jul-2004  21:14  5.0.2195.6960     183,056  Winlogon.exe     
25-Sep-2003  18:08  5.0.2195.6826     243,984  Winsrv.dll       
24-Mar-2004  02:17  5.0.2195.6897     742,160  Kernel32.dll     
14-Jul-2004  01:52  5.0.2195.6960   1,631,696  Win32k.sys
25-Sep-2003  18:08  5.0.2195.6826     243,984  Winsrv.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

To configure how sessions are disconnected on the Windows 2000-based server where Terminal Services is enabled, open Terminal Services Configuration, double-click RDP-Tcp under Connections, and then click the Sessions tab.

For additional information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:

816915 New file naming schema for Microsoft Windows software update packages

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbBug kbfix kbWin2000preSP5fix kbHotfixServer kbQFE KB843564 kbAudEndUser