You cannot establish new Terminal server sessions and Windows 2000 slowly stops responding (843525)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Advanced Server


SYMPTOMS

Microsoft Windows 2000 may slowly stop responding. The following symptoms may occur in the following order:
  1. Any Microsoft Management Console (MMC) snap-in that is running on Windows 2000 stops responding.
  2. The mouse and the keyboard both stop responding.
  3. Terminal server sessions stop responding.
  4. You cannot establish new Terminal server sessions.
  5. Programs that are running on Windows 2000 stop responding.
  6. When the server stops responding, you must restart the server.

CAUSE

This problem may occur when the Client/Server Runtime SubSystem (CSRSS) process is waiting for a resource to become available. However, the resource that the CSRSS process is waiting for cannot become available because font-related semaphores are not released across the kernel/user boundary.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To apply this hotfix, you must have Windows 2000 Service Pack 3 or Windows 2000 Service Pack 4 installed on your computer.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time    Version         Size       File name
   ------------------------------------------------------------
   24-Mar-2004  02:17   5.0.2195.6824     42,256   Basesrv.dll
   21-Sep-2003  00:45   5.0.2195.6824    236,304   Cmd.exe
   12-Jun-2004  01:22   5.0.2195.6932    231,184   Gdi32.dll
   24-Mar-2004  02:17   5.0.2195.6897    742,160   Kernel32.dll
   12-Jun-2004  01:22   5.0.2195.6898     37,136   Mf3216.dll
   24-Mar-2004  02:17   5.0.2195.6824     54,544   Mpr.dll
   12-Jun-2004  01:22   5.0.2195.6930    335,120   Msgina.dll
   24-Mar-2004  02:17   5.0.2195.6892     90,264   Rdpwd.sys
   04-Jun-2004  23:13   5.0.2195.6935  5,887,488   Sp3res.dll
   24-Mar-2004  02:17   5.0.2195.6897    403,216   User32.dll
   05-Aug-2003  22:14   5.0.2195.6794    385,808   Userenv.dll
   10-Jun-2004  00:06   5.0.2195.6940  1,631,408   Win32k.sys
   11-Mar-2004  02:37   5.0.2195.6898    181,520   Winlogon.exe
   25-Sep-2003  18:08   5.0.2195.6826    243,984   Winsrv.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

REFERENCES

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

816915 New naming schema for Microsoft Windows hotfix packages

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbBug kbfix kbWin2000preSP5fix kbHotfixServer kbQFE KB843525 kbAudITPRO kbAudDeveloper