An Exchange 2000 Server-side forwarding rule may not forward e-mail messages as expected (843460)



The information in this article applies to:

  • Microsoft Exchange 2000 Server

SYMPTOMS

When you send an e-mail message by using Lotus Notes to a Public folder that has a forwarding rule applied, the Exchange 2000 Server-side forwarding rule may not forward the e-mail message as expected.

CAUSE

This problem may occur if the following conditions are true in the order that they are presented:
  1. You send an e-mail message from Lotus Notes over a Lotus Notes Connector to a Microsoft Exchange Server version 5.5 organization.
  2. The Exchange Server 5.5 server uses a server-side forwarding rule to send the e-mail message over a X.400 connector to a Microsoft Exchange 2000 Server organization.
  3. In the Exchange Server 5.5 organization, the recipient address is a X.400 custom recipient. However, in the Exchange 2000 Server organization, the recipient is a distribution list that contains multiple public folders that also have server-side forwarding rules applied.
In this scenario, the e-mail message arrives successfully in the public folders. However, the PR_MESSAGE_TO_ME, the PR_MESSAGE_CC_ME, and the PR_MESSAGE_RECIP_ME properties may be removed after the e-mail message arrives in the public folders. Therefore, the e-mail message cannot be forwarded.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Exchange 2000 Server service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart the computer after you apply this software update.

Hotfix replacement information

This hotfix does not replace any other software updates.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version       Size       File name
   ---------------------------------------------------------
   31-Jul-2004  23:39  6.5.6980.94      20,480  Exhotfix.dll     
   13-Sep-2004  04:47  6.0.6617.6    2,310,144  Mdbmsg.dll       
   12-Sep-2004  05:02  6.0.6617.6    4,685,824  Store.exe        
   15-Sep-2004  02:24                    1,824  Exhotfix.cdf
   31-Jul-2004  23:39  6.5.6980.94      20,480  Exhotfix.dll
Note Because of file dependencies, this update requires Microsoft Exchange 2000 Server Service Pack 3 (SP3).

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

301378 How to obtain the latest Exchange 2000 Server service pack


STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Modification Type:MinorLast Reviewed:10/9/2006
Keywords:kbQFE kbHotfixServer kbfix kbExchange2000preSP4fix kbbug KB843460 kbAudITPRO