You receive a "One of the files in the registry database had to be recovered" message when you connect a Windows XP-based client computer to a Windows NT 4.0 domain (843426)



The information in this article applies to:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition

SYMPTOMS

When you log your Microsoft Windows XP-based client computer on to a Windows NT 4.0 domain, you may receive the following message: One of the files in the registry database had to be recovered by use of a log or alternate copy. The recovery was successful.If you configure the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SessionManager\Configuration Manager\SelfHealingEnabled registry key to turn on the registry self-healing feature, an Event ID 1508 event message may be logged in the Windows XP-based computer.

CAUSE

This problem may occur if you install the KB818133 hotfix or Microsoft Security Bulletin MS04-032.

Note If you cannot install Windows XP SP2 at this time, this fix can be applied after installing Security Bulletin MS04-032.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel. Windows XP, 32-bit versions
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   11-Jul-2004  10:54  5.1.2600.1575   1,899,008  Ntkrnlmp.exe     
   11-Jul-2004  10:55  5.1.2600.1575   1,954,816  Ntkrnlpa.exe     
   11-Jul-2004  10:55  5.1.2600.1575   1,926,656  Ntkrpamp.exe     
   12-Jul-2004  11:00  5.1.2600.1575   2,051,712  Ntoskrnl.exe     
Windows XP, 64-bit versions
Date          Time   Version           Size    File name    Platform 
-------------------------------------------------------------------- 
10-July-2004  03:38  5.1.2600.1575  5,831,424  Ntkrnlmp.exe IA-64 
10-July-2004  03:38  5.1.2600.1575  5,774,720  Mtoskrnl.exe IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows XP Service Pack 2.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbWinXPsp2fix kbWinXPpreSP2fix kbfix kbbug KB843426 kbAudITPRO