Users can map a network drive in a Terminal Services session even after you enable the "Remove 'Map Network Drive' and 'Disconnect Network Drive'" Group Policy setting in Windows Server 2003 (843356)



The information in this article applies to:

  • Microsoft Windows Server 2003, Standard Edition
  • Microsoft Windows Server 2003, Enterprise Edition
  • Microsoft Windows Server 2003, 64-Bit Enterprise Edition

SYMPTOMS

When you enable the "Remove 'Map Network Drive' and 'Disconnect Network Drive'" Group Policy setting in Microsoft Windows Server 2003, users who connect to the server through a Terminal Services session may still be able to map a network drive. The Map Network Drive dialog box is displayed when a user clicks Network in the Print to File dialog box of some programs. For example, users can still map a network drive if they connect to the server through a Terminal Services session from a client computer and then follow these steps:
  1. Start a program, such as Microsoft Internet Explorer. On the Help menu, click Contents and Index.
  2. On the Options menu, click Print, click the option to print the topics that you want, and then click OK.
  3. In the Print dialog box, click to select the Print to file check box, and then click Print.
  4. In the Print to File dialog box, click Network.

    The Map Network Drive dialog box is displayed.

CAUSE

This problem occurs if the OFN_NONETWORKBUTTON flag is not set correctly. In this scenario, the Network button is available as an option in the Print to File dialog box.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Windows Server 2003

Date         Time   Version        Size     File name
--------------------------------------------------------
22-Jun-2004  17:58  6.0.3790.184   266,752  Comdlg32.dll 

Windows Server 2003, 64-Bit Edition

Date         Time   Version        Size    File name
---------------------------------------------------------------
22-Jun-2004  17:53  6.0.3790.184  722,944  Comdlg32.dll   IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information about terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbBug kbfix kbWinServ2003preSP1fix KB843356 kbAudITPRO