The computer may stop responding and CPU utilization for Internet Explorer may remain high for a long time when you view a Web page (843268)



The information in this article applies to:

  • Microsoft Internet Explorer 6.0 SP1

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

When you view a Web page in Microsoft Internet Explorer 6 Service Pack 1 that uses absolute positioning together with dynamic HTML (DHTML) element behaviors, you may notice that the memory for the Iexplore.exe process increases at a fast rate until the computer stops responding (hangs) and CPU utilization for Internet Explorer may remain high for a long time.

CAUSE

This problem occurs when Internet Explorer displays absolute positioned elements on a Web page and processes a DTHML element behavior on the <BODY> HTML tag.

RESOLUTION

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Internet Explorer 6 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Internet Explorer 6.0 SP1

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix replaces a hotfix that is available on the http://hotfix Web site. However, information about that hotfix was never published in a Microsoft Knowledge Base article. The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   17-Jun-2004  00:01  6.0.2800.1449   2,692,096  Mshtml.dll   

Installation information

To turn on this hotfix, follow these steps:
  1. Quit Internet Explorer.
  2. Click Start, click Run, type regedit, and then click OK.
  3. Locate, and then click the following registry subkey:

    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Internet Explorer\Main

  4. Right-click the Main entry, point to New, and then click Key.
  5. Type FeatureControl, and then press ENTER.
  6. Right-click the FeatureControl entry, point to New, and then click Key.
  7. Type KB843268_Performance_Issue, and then press ENTER.
  8. Right-click the KB843268_Performance_Issue entry, point to New, and then click DWORD Value.
  9. Type Iexplore.exe, and then press ENTER.
  10. Right-click Iexplore.exe, and then click Modify.
  11. In the Value data box, type 00000001, and then click OK.
  12. Close Registry Editor.

WORKAROUND

If you can make changes to the Web page, you may be able to work around this problem by changing the Web page so that it does not use absolute positioning for the <BODY> HTML tag.

STATUS

Microsoft has confirmed that this is a problem in Microsoft Internet Explorer 6.

Modification Type:MinorLast Reviewed:3/31/2006
Keywords:kbHotfixServer kbQFE kbIE600sp2fix kbIE600preSP2fix KB843268 kbAudITPRO kbAudEndUser