Shared disk cluster resource may not come online on Windows 2000 Server (843157)



The information in this article applies to:

  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server

SYMPTOMS

When a Microsoft Windows 2000 Server-based computer that is in a clustered environment tries to mount a volume, the volume-mount operation may take several minutes and time out, and the resource may not come online.

CAUSE

This behavior may occur when there are several disk quotas that are applied to the volume.

WORKAROUND

To work around this behavior, increase the Pending Timeout value for the shared disk resource:
  1. Start Cluster Administrator.
  2. Right-click the shared disk resource that you want to change, click Properties, and then click the Advanced tab.
  3. Increase the Pending Timeout value to provide more time for the volume to mount. By default, the Pending Timeout value is 180 seconds.

MORE INFORMATION

Before Windows 2000 Server mounts a volume that has disk quotas, it scans the volume to update the quota index. When several disk quotas are applied to the volume, it may take several minutes to complete the scanning procedure. This may cause the Pending Timeout period to expire before the volume-mount operation is completed.

The quota index scanning procedure occurs in the following scenarios:
  • The disk quotas are first applied to the volume.
  • Corruption is detected in the quota index.
  • The Chkdsk.exe utility makes a change to one or more files or folders on the hard disk volume.
For additional information about how to configure disk quotas for shared disks, click the following article number to view the article in the Microsoft Knowledge Base:

278365 How to configure disk quotas for a shared disk in a cluster

For additional information about disk quotas, click the following article number to view the article in the Microsoft Knowledge Base:

183322 How to enable disk quotas in Windows 2000


Modification Type:MajorLast Reviewed:11/12/2004
Keywords:kbClustering kbprb KB843157 kbAudITPRO