The Internet Explorer Address bar is missing (842903)



The information in this article applies to:

  • Microsoft Internet Explorer 6.0
  • Microsoft Internet Explorer 6.0 SP1

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

The Address bar may be missing in Microsoft Internet Explorer 6.

CAUSE

This issue may occur if the Toolbar settings are set to remove the Address bar, or if there is a problem with a registry key.

RESOLUTION

To resolve this issue, change the Toolbar settings, or delete the WebBrowser registry key.

Method 1: Change the Toolbar settings

To change the Toolbar settings:
  1. Start Internet Explorer, click View and then point to Toolbars.
  2. If there is not a check mark next to Address Bar, click Address Bar to place the check mark. If there is a check mark next to Address Bar, click Address Bar to remove the check mark, and then click Address Bar to place the check mark.
  3. If the Address bar is in the upper right corner and not available, right-click Address, and then click Lock the Toolbar to remove the check mark.
  4. Click Address, and then drag the Address bar where you want it.
If the problem is still not resolved, go to Method 2.

Method 2: Delete the WebBrowser registry key

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To delete the WebBrowser registry key:
  1. Click Start, click Run, type regedit in the Open box, and then click OK.
  2. Locate the following registry key:

    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Toolbar

  3. Right-click the WebBrowser key, click Delete, and then click Yes.
  4. Open Internet Explorer, click View, and then point to Toolbars. The toolbar default settings are restored.

Modification Type:MinorLast Reviewed:8/29/2006
Keywords:kbprb KB842903