"An error was encountered while checking for updates" error message when users try to run a Software Updates package in Systems Management Server 2003 (842717)



The information in this article applies to:

  • Microsoft Systems Management Server 2003

SYMPTOMS

When users try to run a Software Updates package on a client computer in Microsoft Systems Management Server (SMS) 2003, they receive the following error message:
An error was encountered while checking for updates, please contact your system administrator.

CAUSE

This issue may occur if the following conditions are true:
  • You (the SMS administrator) use the Distribute Software Updates Wizard to deploy a Software Updates package.
  • The advertisement for the package does not have a recurring schedule.

RESOLUTION

To resolve this issue, use one of the following methods:
  • When you are prompted by the Distribute Software Updates Wizard, select the option to create the advertisement automatically. By default, the Distribute Software Updates Wizard schedules a recurrence for every seven days.
  • Manually create the software update advertisement, and then specify a recurring schedule.
To manually specify a recurring schedule for an advertisement, follow these steps:
  1. Start the SMS Administrator console.
  2. Right-click Advertisements, point to New, and then click Advertisement.
  3. On the Schedule tab, click the new mandatory assignment button (the yellow-star icon), and then click Schedule.
  4. In the Schedule dialog box, click one of the following options in the Recurrence Pattern area, and then accept or change the default recurrence schedule:
    • Interval
    • Weekly
    • Monthly
  5. Click OK three times.

MORE INFORMATION

Advertisements that are created for the Software Updates Installation Agent (PatchInstall.exe) must have a recurrence schedule. When advertisements recur on a set schedule, client computers can periodically evaluate new settings and authorized updates. When you use the Distribute Software Updates Wizard to configure a Software Updates package, you have the following options:
  • Let the Distribute Software Updates Wizard create the advertisement for you.
  • Manually create the advertisement later.
If the Distribute Software Updates Wizard creates the advertisement, the recurrence schedule is automatically defined. If you manually create the advertisement, you must manually configure the recurrence schedule.

You can also configure the advertisement to allow a user to postpone the advertisement. When the advertisement schedule is not set to recur, and a user postpones the advertisement, the user receives the error message that is mentioned in the "Symptoms" section when the user tries to run the advertisement later.

Modification Type:MinorLast Reviewed:6/13/2005
Keywords:kbAdvertisement kbPackage kbClient kbsmsUtil kberrmsg kbtshoot kbUser kbusage kbSoftwareDist kbMiscTools kbfix kbnofix kbBug KB842717 kbAudITPRO