You receive a "Shared library" error message when you start Office for Mac programs (842646)



The information in this article applies to:

  • Microsoft Office 2004 for Mac Standard Edition
  • Microsoft Office 2001 for Mac
  • Microsoft Office v. X for Mac

SYMPTOMS

When you try to start a Microsoft Office for Mac program, the program does not start, and you may receive the following error message:
Shared library error (Carbonlib) May also occur with Internet Explorer 5.2 for Mac

CAUSE

This problem may occur if the CarbonLib file in Mac OS X is damaged or is corrupted.

RESOLUTION

The damaged file belongs to the Mac Operating System. To resolve this problem, follow these steps:
  1. Repair disk permissions. Use the Disk Utility to repair and then verify disk permissions.
  2. Restart the system, and then check to see whether all programs start.
  3. Perform an "Archive and Installation" of Mac OS X. Click the following link to find the details of this procedure:
Note Apple Technical Support has requested that you take these steps before you telephone for support. Apple Technical Support can be contacted at 1-800-767-2775.

MORE INFORMATION

For more information about how to use Disk Utility and fsck to resolve startup issues or perform disk maintenance, visit the following Apple Web site:For more information about the Archive and Install feature, visit the following Apple Web site: For more information about how to troubleshoot a software issue, visit the following Apple Website: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

Modification Type:MajorLast Reviewed:2/16/2006
Keywords:kberrmsg kbprb KB842646 kbAudEndUser