Messages may not be delivered when you use the Filter messages with blank sender option in Exchange 2000 Server (842588)



The information in this article applies to:

  • Microsoft Exchange 2000 Server

SYMPTOMS

When you use the Filter messages with blank sender option in Microsoft Exchange 2000 Server, some messages that do have a sender may not be delivered. Messages may be incorrectly filtered as having a blank sender.

CAUSE

The problem occurs if one of the following conditions is true:
  • The From box of the message contains a comment.
  • The From box of the message contains a single-byte character set (SBCS) space between double-byte character set (DBCS) characters.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Exchange Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Because of file dependencies, this update requires Microsoft Exchange 2000 Server Service Pack 3 (SP3). For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

301378 How to obtain the latest Exchange 2000 Server service pack


File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
     Date         Time   Version            Size    File name
   --------------------------------------------------------------
   19-Jun-2003  20:05  5.0.2195.6654     322,320  Aqueue.dll       
   19-Jun-2003  20:05  5.0.2195.6666      67,344  Mailmsg.dll      
   19-Jun-2003  20:05  5.0.2195.6662      38,672  Ntfsdrv.dll      
   06-Aug-2004  17:52  5.0.2195.6966     446,736  Smtpsvc.dll    

STATUS

Microsoft has confirmed that this is a problem in Microsoft Exchange 2000 Server.

Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbfix kbExchange2000preSP4fix kbbug KB842588 kbAudITPRO