FIX: Unattended installation with Message Queuing Down Level Client Support may not succeed if the MQDS option is selected (842511)



The information in this article applies to:

  • Microsoft Message Queuing 3.0

SYMPTOMS

Microsoft Message Queuing cannot be installed when an unattended installation is performed if the Message Queuing Down Level Client Support (MQDS) option is selected, and the MQDS service takes too long to start. A dialog box appears during the unattended installation when the service does not start in the wait-time default. You can click Retry in the dialog box to make the Setup succeed. However, user intervention is not desirable during an unattended installation.

CAUSE

During unattended installation, MQDS timesout because the wait-time default is too brief for large enterprises.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   20-May-2004  15:18  5.4.15.0          120,560  Windowsserver2003-kb842511-x86-enu-symbols.exe  
   20-May-2004  15:19  5.4.15.0          402,160  Windowsserver2003-kb842511-x86-enu.exe  
   20-May-2004  16:23  5.2.1726.173      240,128  Msmqocm.dll      
   21-Apr-2004  16:35                        271  Branches.inf
   20-May-2004  17:09                      9,766  Kb842511.cat
   20-May-2004  16:43                        354  Updatebr.inf
   20-May-2004  16:44                      5,657  Update_rtmqfe.inf

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:

816915 New file naming schema for Microsoft Windows software update packages


Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbBug kbfix kbWinServ2003preSP1fix kbHotfixServer kbQFE KB842511 kbAudDeveloper