SMS Security Scan tool does not work and you receive a "Message ID:11406" SMS status message (842488)



The information in this article applies to:

  • Microsoft Systems Management Server 2003

SYMPTOMS

The advertisement of the Software Update Inventory Scan Tools (Scanwrapper.exe) in Microsoft System Management Server (SMS)does not work , and you may receive the following SMS status message: Message ID:11406, Component: Software Update Scan Tool
Scan Component Failed(type=MBSA): probably due to a schema change or WMI error.

The Software Updates class for SMS clients may either not be present within the Resource Explorer, or contain out of date information.

The Advanced Client may not execute further advertisements

CAUSE

This problem may occur if the SMS Advanced client is installed to a folder path that contains a space. For example, the following path contains a space:

C:\Program Files\SMSClient

When you run Scanwrapper.exe on this folder, Scanwrapper.exe cannot run the Mofcomp.exe utility. Therefore, Scanwrapper.exe returns a failure error message to the SMS site server.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next SMS 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question. The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version   Size       File name                         Platform
   -----------------------------------------------------------------------------------
   28-May-2004  22:28  5.3.18.4  3,992,784  Sms2003-rtm-kb842488-x86-enu.exe  i386                  

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

824684 Description of the standard terminology that is used to describe Microsoft software updates


Modification Type:MinorLast Reviewed:6/5/2006
Keywords:kbHotfixServer kbQFE kbfix kbBug KB842488 kbAudITPRO