You receive the "Error accessing file. Network connection may have been lost" error message when you run a VBA macro that copies a presentation to a new presentation in PowerPoint 2003 (842315)



The information in this article applies to:

  • Microsoft Office PowerPoint 2003

For a Microsoft PowerPoint 2002 version of this article, see 840652.
Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows registry

SYMPTOMS

When you run a Microsoft Visual Basic for Applications (VBA) macro that copies a presentation to a new presentation in Microsoft Office PowerPoint 2003, you receive the following error message:
Error accessing file. Network connection may have been lost.

CAUSE

This problem occurs when all the following conditions are true:
  • The presentation that is being copied was created in an earlier version of Microsoft PowerPoint.
  • The presentation that was created in an earlier version of PowerPoint contains an embedded Microsoft Excel worksheet that also has an embedded ActiveX control.
  • The VBA macro contains an Open event that searches for OLE objects.

RESOLUTION

This problem was first fixed in a hotfix that is now contained in a service pack. If you installed the latest Office 2003 service pack, you do not have to install the hotfix.

Service pack information

This problem is corrected in Office 2003 Service Pack 2.

To resolve this problem, obtain the latest service pack for Office 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

870924 How to obtain the latest service pack for Office 2003



After you install the service pack, follow the steps that are listed in the "More Information" section of the article to set the Hotfix12394 registry key and to activate the hotfix.

Hotfix information

How to obtain the hotfix

This issue is fixed in the PowerPoint 2003 post-Service Pack 1 Hotfix Package that is dated August 20, 2004. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

839630 Description of the PowerPoint 2003 post-Service Pack 1 hotfix package: August 20, 2004

After you install this hotfix, follow the steps that are listed in the "More Information" section of this article to set the Hotfix12394 registry key and to activate the hotfix.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Office 2003 Service Pack 2.

MORE INFORMATION

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

To this hotfix, follow these steps:
  1. Quit PowerPoint 2003.
  2. Click Start, click Run, type regedit, and then click OK.
  3. Locate and then click to select the following registry key:

    HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\PowerPoint\Options

  4. After you select the key that is specified in step 3, point to New on the Edit menu, and then click DWORD Value.
  5. Type Hotfix12394, and then press ENTER.
  6. Right-click Hotfix12394, and then click Modify.
  7. In the Value data box, type 1, and then click OK.
  8. On the File menu, click Exit to quit Registry Editor.

Modification Type:MajorLast Reviewed:4/7/2006
Keywords:kbQFE KBHotfixServer kbOffice2003SP2fix kbOffice2003preSP2fix kbfix kbbug KB842315 kbAudITPRO kbAudEndUser