"Error accessing file. Network connection may have been lost." error message when you run a VBA macro that copies a presentation to a new presentation in PowerPoint 2000 (842314)



The information in this article applies to:

  • the operating system: Microsoft Windows Server 2003
  • the operating system: Microsoft Windows XP Professional
  • the operating system: Microsoft Windows 2000
  • Microsoft PowerPoint 2000

For a Microsoft PowerPoint 2002 version of this article, see 840652.
Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you run a Microsoft Visual Basic for Applications (VBA) macro that copies a presentation to a new presentation in Microsoft PowerPoint 2000, you receive the following error message:
Error accessing file. Network connection may have been lost

CAUSE

This problem occurs when all the following conditions are true:
  • The presentation that is being copied was created in an earlier version of Microsoft PowerPoint.
  • The presentation that was created in an earlier version of PowerPoint contains an embedded Microsoft Excel worksheet that also has an embedded ActiveX control.
  • The VBA macro contains an Open event that searches for OLE objects.

RESOLUTION

How to obtain the hotfix

This issue is fixed in the PowerPoint 2000 post-Service Pack 3 Hotfix Package that is dated June 4, 2004. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

842785 Description of the PowerPoint 2000 post-Service Pack 3 hotfix package: June 4, 2004


After you install this hotfix, follow the steps that are listed in the "More Information" section of this article to set the Hotfix12395 registry key and to activate the hotfix.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry


To activate this hotfix, follow these steps:
  1. Quit PowerPoint 2000.
  2. Click Start, and then click Run.
  3. In the Open box, type regedit, and then click OK.
  4. Locate, and then click to select the following registry key:

    HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\PowerPoint\Options

  5. After you select the key that is specified in step 4, point to New on the Edit menu, and then click DWORD Value.
  6. Type Hotfix12395, and then press ENTER.
  7. Right-click Hotfix12395, and then click Modify.
  8. In the Value data box, type 1, and then click OK.
  9. On the File menu, click Exit to quit Registry Editor.

Modification Type:MajorLast Reviewed:4/7/2006
Keywords:kbQFE KBHotfixServer kberrmsg kbScript kbAutomation kbProgramming kbOffice2000preSP4fix kbfix kbbug KB842314 kbAudEndUser kbAudITPRO kbAudDeveloper