You receive a "Cannot play back the video stream" error message in Windows Media Player (842182)



The information in this article applies to:

  • Microsoft Windows Media Player for Windows XP Home Edition
  • Microsoft Windows Media Player for Windows XP Professional
  • Microsoft Windows Media Player 7.1
  • Microsoft Windows Media Player 7
  • Microsoft Windows Media Player 6.4
  • Microsoft Windows Media Player 6.1
  • Microsoft Windows Media Player 6.0
  • Microsoft Windows Media Player 9 Series for Windows XP
  • Microsoft Windows Media Player 9 Series for Windows Server 2003
  • Microsoft Windows Media Player 9 Series for Windows 2000
  • Microsoft Windows Media Player 9 Series for Windows Millennium Edition
  • Microsoft Windows Media Player 9 Series for Windows 98 Second Edition

Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you try to play a file in Windows Media Player, you may receive the following error message:
Cannot play back the video stream: no suitable decompressor could be found. (Error=80040255)

CAUSE

This error message may occur if one of the following conditions is true:
  • You may be playing a file that was created by using Apple QuickTime version 3 or 4.
  • You may be playing a file format that is not supported by Windows Media Player.
  • The codec that is required to play the file is missing or damaged.
  • Some of the Windows Media Player files are missing or damaged.
  • The media file is damaged.

RESOLUTION

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To troubleshoot this problem, follow these steps. Test to determine if the issue is resolved after each step.

Note Windows Media Player does not support playing every kind of media file that is currently available but does provide support for the most common kinds of media files. Make sure that your media file is a supported kind. If your media file is not a supported kind, do not perform the steps after step 1. If Windows Media Player does not support the file format that you are using, contact the distributor of the file to inquire about the availability of a viewer for the file.
  1. Verify that Windows Media Player supports the file format that you are using. Windows Media Player supports the following file formats:
    • Windows Media formats: .asf, .asx, .avi, .wav, .wax, .wma, .wm, .wmv
    • Moving Pictures Experts Group (MPEG) formats: m3u, mp2v, .mpg, .mpeg, .m1v, .mp2, .mp3, .mpa, .mpe, mpv2
    • Musical Instrument Digital Interface (MIDI) formats: .mid, midi, .rmi
    • UNIX File formats: .au, .snd
    Note Windows Media Player does not support playing .avi files that are created by using the Microsoft MPEG4v3 codec. The file must be encoded again by using the original source in a supported format such as the .asf format. To do this, you can use the Windows Media tools. For additional information, visit the following Microsoft Web site:If you have access to the original source, contact the creator of the file and request that the creator convert the file to a kind of file that Windows Media Player supports. Microsoft supports MPEG4v3 files in .asf streaming format only. These files are not supported in an .avi file.
  2. Verify that you can play a media file that uses the same file name extension as the file that you were playing when you received the error message.

    For additional information about file formats that Windows Media Player supports, click the following article number to view the article in the Microsoft Knowledge Base:

    316992 Windows Media Player multimedia file formats

    If the other file plays correctly, the original file that you were trying to play may be damaged. If you receive an error message when you play both files, go to the next step.
  3. Remove Windows Media Player, restart the computer, and then reinstall Windows Media Player. To remove Windows Media Player, follow these steps:
    1. Click Start, click Control Panel, and then double-click Add/Remove Programs.
    2. Click Add/Remove Windows Components.
    3. Click to select Windows Media Player, and then click Next.
    4. Click Finish, and then close Add/Remove Programs.
  4. Reinstall the latest version of Microsoft DirectX.

    For additional information about troubleshooting and installing DirectX, click the following article numbers to view the articles in the Microsoft Knowledge Base:

    179113 How to download and install DirectX

    157730 How to determine the version of DirectX using the DirectX Diagnostic Tool

  5. Verify that you are using the correct codec for the media file that you are trying to play.

    For additional information about how to verify, install, and troubleshoot audio codecs, click the following article numbers to view the articles in the Microsoft Knowledge Base:

    142731 How to install and remove codecs and MCI devices in Windows

    141801 Troubleshooting audio and video codecs in Windows 95/98

    191533 Media Player cannot play .avi file using Indeo 4.x codec

    221831 Err msg: Unable to download the appropriate decompressor

  6. Verify that the following registry key and its associated values exist.

    HKEY_CLASSES_ROOT\CLSID\{DA4E3DA0-D07D-11d0-BD50- 00A0C911CE86}\Instance\{083863F1-70DE-11d0-BD40-00A0C911CE86}

    Note This registry key is one path. It has been wrapped for readability.

    This key should have the following value name and value data information:

    CLSID={083863F1-70DE-11d0-BD40-00A0C911CE86}


    FriendlyName = DirectShow Filters
    Merit (DWORD value) = 00600000

    If this key does not exist, create it. To create the key, follow these steps:
    1. Click Start, click Run, type regedit, and then click OK.
    2. Locate and then click the following key in the registry:

      HKEY_CLASSES_ROOT\CLSID\{DA4E3DA0-D07D-11d0-BD50-00A0C911CE86}\Instance

    3. On the Edit menu, point to New, and then click Key.
    4. Type {083863F1-70DE-11d0-BD40-00A0C911CE86}, and then press ENTER.
    5. On the Edit menu, point to New, and then click String Value.
    6. Type CLSID, and then press ENTER.
    7. On the Edit menu, click Modify.
    8. Type {083863F1-70DE-11d0-BD40-00A0C911CE86}, and then click OK.
    9. On the Edit menu, point to New, and then click String Value.
    10. Type FriendlyName, and then press ENTER.
    11. On the Edit menu, click Modify.
    12. Type DirectShow Filters, and then click OK.
    13. On the Edit menu, point to New, and then click DWORD Value.
    14. Type Merit, and then press ENTER.
    15. On the Edit menu, click Modify.
    16. Type 600000, and then click OK.
    17. Quit Registry Editor.

REFERENCES

For additional information about Windows Media Player invalid file format error message, click the following article number to view the article in the Microsoft Knowledge Base:

234019 Windows Media Player invalid file format error message


Modification Type:MajorLast Reviewed:7/21/2004
Keywords:kbprb kberrmsg KB842182 kbAudEndUser