An incorrect display name appears in the From field of an e-mail message that is sent from a user in one Exchange 2000 Server organization to a user in another Exchange 2000 Server organization (842146)



The information in this article applies to:

  • Microsoft Exchange 2000 Server

SYMPTOMS

Consider the following scenario:
  • A user who is named "User A" exists in a Microsoft Exchange 2000 Server organization that is named "Organization A."
  • In your Exchange 2000 organization that is named "Organization B," you create a contact for User A.
  • User A sends an e-mail message by using Microsoft Outlook to a user in Organization B.
You expect the display name that appears in the From field of this e-mail message to be that of the contact that you created for User A in your Exchange organization, Organization B. However, in this scenario, the display name that actually appears in the From field of this e-mail message is the display name from User A's organization, Organization A.

If the sender's display name from Organization A contains characters from a character set that does not appear correctly in your Exchange organization, the sender's display name might not appear correctly to Outlook users in your Exchange organization.

CAUSE

This issue occurs if the user from the source organization sends the e-mail message in Rich Text Format (RTF). If the message is sent by using plain text format or by using HTML format, the From field of the message contains the display name of the contact that you configured in the destination organization.

Note In this scenario, Organization A is the source organization and Organization B is the destination organization.

The PR_SENDER_NAME property contains the message sender's display name. This issue occurs because the PR_SENDER_NAME property does not use the resolved contact's display name for RTF messages.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Only apply it to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Exchange Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

Because of file dependencies, this hotfix requires Microsoft Exchange 2000 Server Service Pack 3 (SP3). For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

301378 How to obtain the latest Exchange 2000 Server service pack

Restart requirement

You do not have to restart your computer after you apply this hotfix. However, many Exchange-related services are automatically stopped and then restarted when you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   ---------------------------------------------------------
   13-Sep-2004  04:47  6.0.6617.6      2,310,144  Mdbmsg.dll
   12-Sep-2004  05:02  6.0.6617.6      4,685,824  Store.exe 
After you apply this hotfix, when a message sender has a corresponding contact in the destination Exchange organization, the display name of the contact appears in the From field of the e-mail message. This new behavior occurs even if the sender's server that is running Exchange 2000 does not preserve the display name.

STATUS

Microsoft has confirmed that this is a problem in Microsoft Exchange 2000 Server.

Modification Type:MinorLast Reviewed:6/1/2006
Keywords:kbQFE kbHotfixServer kbfix kbExchange2000preSP4fix kbbug KB842146 kbAudITPRO